"Wrong used space" on Kimsufi 2TB


#1

Good evening
I just installed Quickbox on Ubuntu 16.04 on a Kimsufi 2TB with / and / home. I installed rTorrent, Plex, Sonarr, Radarr
In the Used disk section, there is written 92GB. By browsing the forum I read this topic: Kimsufi server not showing correct disk usage

So I used the command: fix-disk_widget_home, but the result remains the same.
With the lsblk command I get

KS4-C:~# lsblk
NAME   MAJ:MIN RM    SIZE RO TYPE MOUNTPOINT
sda      8:0    0    1.8T  0 disk 
├─sda4   8:4    0    511M  0 part [SWAP]
├─sda2   8:2    0   14.7G  0 part /
├─sda3   8:3    0    1.8T  0 part /home
└─sda1   8:1    0 1004.5K  0 part 

I know there is the 5% reserve, but on reading several posts I understood that the above commands removed them.
Did I make a mistake?

Thank you


#2

The fix-disk_widget_home command simply tells the widget for the disk as well as rtorrent to make use of the /home partition for reading the amount of space available on the system. Unfortunately, it does not also decrease or remove the limits for the reserve.

You could (as suggested in that thread) install quotas as well. That way it only shows the amount of spaced used by your own files and not also those of the filesystem. However, as you know, the reserved amount would still be there and you’d only be fooling yourself :smiley:


#3

Thank you for this quick response. Pity to lose those 5%
Still thank you for this script :slight_smile:


#4

There is this after a google search:

You would more than likely have to set your system in Rescue mode (if that’s an option). I’m not much in tampering with reserved blocks, but that article could be a good clue.

More on tune2fs here:


Quota does not work and disk space error
#5

Thank you very much, but my experience on linux is very small. Now my seedbox works perfectly so is good for me :blush:


#6

to use your disk efficient - for big files - do this:

  1. save all data of /dev/sda3

recreate your filesystem on this partition:

mkfs.ext4 -T largefile4 -m 0 /dev/sda3
-> -T largefile4 changes the ratio bytes to inodes.
-> -m 0 changes the reserved space (default 5% - on your sda3 -> 92GB) to 0%. The reserved space is only necessary on the partition with the root filesystem, your sda2.
-> further infos: https://wiki.archlinux.org/index.php/ext4#Bytes-per-inode_ratio

or 2)
when you wouldn’t recreate your filesystem, you can reduce the reserved space without dataloss the following way:
tune2fs -m 0 /dev/sda3