Kimsufi server not showing correct disk usage


#1

Hey everyone,
Just stumbled on this script and thought it would be awesome. Install went fine, but now I am having some post installation woes.

I am using Debian
My entire file system is on root as I deleted the home partition
My server is 2tb

Now for the issues. The disk status widget looks like this:

Im not sure what to do about it. Im currently setting up plex and my other desired packages, but the widget is really bugging me. Thanks in advance for your help!

Also why is the installation 96GB in size? I have no torrents or anything downloaded at the time of taking that screen shot.


"Wrong used space" on Kimsufi 2TB
#2

This is in no part due to QuickBox. By default Linux installs reserve 5% of the disk… here’s a bit more as to why:

Saving space for important root processes (and possible rescue actions) is one reason. If you allow others to log on to your system, via ssh, for example, having these 5% blocks reserved ensures external users cannot fill the disk. Even if you don’t allow others to log in to your system, the reserved blocks prevents programs not running as root from filling your disk.

If you set the reserved block count to zero, it won’t affect performance much except if you run for long periods of time (with lots of file creates and deletes) while the filesystem is almost full (i.e., say above 95%), at which point you’ll be subject to fragmentation problems.


As per the widget, I have never seen behavior like this on any install. Could you perform the following to see if this addresses it.

cp /root/QuickBox/dashboard/widgets/disk_data.php /srv/rutorrent/home/widgets/disk_data.php

Select ‘yes’ if it as you to overwrite and then do service apache2 restart


#3

I have the exact same Kimsufi setup as OP and I am also suffering the same issue.

Upon initial Debian install, the /home partition was deleted and the / directory had been configured to “Use the remaining space”. Quotas was disabled on install as I am a single user and I am also using the original Debian kernel.

I just tried your fix JMSolo but unfortunately I am still seeing the same issue.


#4

Could one of the two of you PM me your server details so I may troubleshoot this directly?


#5

PM sent. Hope you can find a fix for it :slight_smile:


#6

Thanks for the details @sadpanda and allowing me to review this directly for a fix. I have you all patched up and have pushed the update.

Anyone else with the issue here is what you can do:
Update QuickBox either through cli or directly on your dashboard. The command for updating via cli is box upgrade
Next, copy the updated widget to your dashboard. By default we do not overwrite the Disk Widget on updates.

cp /root/QuickBox/dashboard/widgets/disk_data.php /srv/rutorrent/home/widgets/disk_data.php
service apache2 restart

If you are running a /home mount install:

cp /root/QuickBox/dashboard/widgets/disk_datah.php /srv/rutorrent/home/widgets/disk_data.php
service apache2 restart

Remember to select ‘yes’ if prompted to overwrite the current file.


####Here is the commit for review if anyone is interested.


#7

Thanks for the help JMSolo!
I and am sure Olympus are very happy with the latest comits. :smiley:


#8

Well this sure is nice to come home to! Awesome development and community so far. Thanks so much.


#9

Hello Guys, how are you?

I’ve installed Quickbox recently on a Kimsufi and I’m getting the same problem. I have the partitions like these.
/ 10240
/home (remain space)
/ 512Mb Swap

Quotas was disable on install and It has only one user.

If I use this it shows me

cp /root/QuickBox/dashboard/widgets/disk_data.php /srv/rutorrent/home/widgets/disk_data.php
service apache2 restart

If I use this it shows me

If you are running a /home mount install:

cp /root/QuickBox/dashboard/widgets/disk_datah.php /srv/rutorrent/home/widgets/disk_data.php
service apache2 restart

So how I could fix it to widgets shows me 0 space used. I don’t have any torrent load.


#10

That looks correct for a Kimsufi install. JMSolo provided an answer as to why it displays 93GB above.


#11

Yes, I read that before and I’m confuse if it is correct or we could put 0 GB used while it doesn’t have any torrent load.


#12

Would enabling quotas help here? Ala:

I have a 1.8TB free on my disk, I set up a quota for my user of 1.8 GBs. Would QB display the space used by the user and not the overall space of the disk?


#13

That’s correct, quotas will only show per the user with the quota assigned.

@YorkiS, since you’re using a /home mount for your primary… try to run fix-disk_widget_home to sort out the disk widget. Additionally, check your /etc/fstab to make absolutely certain that your mount is on /home and not /(root)… which is more than likely the case.

As a side-note: feel free to open a new thread to ask for help rather than asking on an already solved thread for other members… in these situations your query is likely to get overlooked… which is what happened :blush:


#14