Quota does not work and disk space error


I have a problem with Quota, … and a second one I discovered by testing the proposed solutions on the forum.

I am on an Online ST8 server in raid0

It does not work, and displays negative values.
Free: -0.00114059 GB
Used: 0.00114059 GB
Size: 0 GB

I tried to uninstall it,
Free: 6.980 GB
Used: 371 GB ??
Size: 7.351 GB ??

Without quota, it “works”. Unfortunately I need Quota.
(And that’s where I spot a second problem … I have 371GB used on a fresh install? In addition I should have 7.6 TB and not 7.3 in total … I do not understand)

I tried installing everything on / then installing everything on / home (fresh install each time)
The same problems.

I followed

Until the end trying everything.
Without success, but this solution may date a little.

The result of lsdlk when I test in a /home install:

sdb 8:16 0 3.7T 0 disk
├─sdb4 8:20 0 20G 0 part
│ └─md1 9:1 0 20G 0 raid1 /
├─sdb2 8:18 0 300M 0 part
│ └─md0 9:0 0 299.7M 0 raid1 /boot
├─sdb5 8:21 0 3.6T 0 part
│ └─md2 9:2 0 7.2T 0 raid0 /home
├─sdb3 8:19 0 1G 0 part [SWAP]
└─sdb1 8:17 0 1M 0 part
sda 8:0 0 3.7T 0 disk
├─sda4 8:4 0 20G 0 part
│ └─md1 9:1 0 20G 0 raid1 /
├─sda2 8:2 0 300M 0 part
│ └─md0 9:0 0 299.7M 0 raid1 /boot
├─sda5 8:5 0 3.6T 0 part
│ └─md2 9:2 0 7.2T 0 raid0 /home
├─sda3 8:3 0 1G 0 part [SWAP]
└─sda1 8:1 0 1M 0 part

For information, I had to do this to run the server right after the install.

I put forward this solution here:

What can I do? An idea?
Thank you!


Did you run the command fix-disk_widget_home?

Yes, I tried this command in both configuration (/ then / home) according to my partitioning test.

Something just isn’t adding up. If you like, I can PM you and we can take a look at this on your server directly.

That 371GB should obviously be 371MB. This implies that your system is for some reason or another only making use of the /(root) partition, when it should be utilizing /home. If quotas are not installed with those numbers. We may have to simply edit your fstab to make use of the proper mount.

Yes, your system is aligned to have 7.6TB in total, however, don’t forget that Linux reserves a portion of your filesystem to avoid filling a disk to the point where it will never boot again. This reserved space usually defaults at 5% which is reserved and is a safe buffer. Check the following solutions at the topic below if you would like to reduce this buffer.

Hello JMSolo

Yes, it would be nice if you want to watch.

I tried to modify the fstab by adding usrquota as you proposed in your discussion with Ciss:

UUID=6a5161d4-9211-45c9-8920-571fa1b2cec0 / ext4 ,errors=remount-ro 0 1

Modified in:

UUID=6a5161d4-9211-45c9-8920-571fa1b2cec0 / ext4 usrquota,errors=remount-ro 0 1

and I did that after:
quotaoff -a
service quota stop
mount -o remount /
quotacheck -auMF vfsv1
quotaon -uv /
service quota start

Once with the installation on root, another time on / home



So that you can watch being sure that I have not changed things I do not remember, I redid this morning a fresh install, doing the install on / (because that’s what I want originally), and by updating the ST8 network card.
I tried unsuccessfully fix-disk_widget_root at the end.

Regarding the size of the disk, I thought I took into account the 5% in my estimate … ok I must be tired :wink:
I tried handling with tune2fs (root installation) by 1% but it did not change the Quota display.

So, yes PM me please

Did you get the widget to show the proper space?

I’m not sure I understood your question.
I made a fresh install, and I have exactly the same problems.
Do you want ssh access?