upgradePlex not working


#1

When I type “upgradePlex” into console I just get the below. Any idea?


#2

It’s a system command which you are trying to run without sudo. You must either type it as root, or do so as sudo upgradePlex

However, it appears as though some Plex update servers are not reachable. The update notice appears, yet the files are not being pulled via ppa.

I am currently looking into a friendly way to have these .deb packages included in the update command. Once I have a package setup I will include instructions on how to add the upgrade… but first… we test :slight_smile:

###Update

I just tested a theory and this method is safe:

wget https://downloads.plex.tv/plex-media-server/1.0.3.2461-35f0caa/plexmediaserver_1.0.3.2461-35f0caa_amd64.deb
mkdir -p plex-tmp
mv plexmediaserver_*.deb plex-tmp/plexmediaserver_*.deb
cd plex-tmp
dpkg -i plexmediaserver_*.deb
..
rm -rf plex-tmp
service plexmediaserver restart

#3

I just tested sudo and its the same thing.

In what order do I run those commants you just edited with?


#4

All the commands need to be ran as Root; sudo won’t work


#5

What command do you use to get to root then as a user login?


#6

sudo suis the command to gain root from a sudoer.

That is the exact order I posted.


#7

Ok so I just ran it as root and it does this.

I then went into Plex and nothing was updated.


#8

Please take notice of what I advised to you on my initial response.

Make sure you cd to get to the root directory before running those.


#9

Should I run those commands as root? I just wanted to show you that root didn’t do anything either. Do you plan to put those commands into the upgradeplex script?


#10

Yes, I would run all system commands as root to ensure proper firing of the commands.


#12

Can you run this command and then restart Plex from your dashboard.

removepackage-cron

This puts you on systemd, which is the new default for QuickBox. A reboot may be required (it’s highly recommended)

Apologies for this, the pain is far less after you get caught up on this new iteration.


#13

Thanks for the quick reply.

I did #removepackage-cron after I first upgraded to 2.4.x ; however, I just did it again based on your suggestion. Rebooted my server, then restarted Plex from my dashboard.

Same problem as before…?


#14

Can you still access Plex on port 32400?

Also, are you on Debian or Ubuntu?

This does nothing more than update Plex the way they suggest to officially update it. It doesn’t modify any apache settings or directories. It just updates the plex core. Not sure why it would randomly block you out. :confused:

wget https://downloads.plex.tv/plex-media-server/1.0.2.2413-7caf41d/plexmediaserver_1.0.2.2413-7caf41d_amd64.deb
mkdir -p plex-tmp
mv plexmediaserver_*.deb plex-tmp/plexmediaserver_*.deb
cd plex-tmp
dpkg -i plexmediaserver_*.deb
..
rm -rf plex-tmp
service plexmediaserver restart

#15

Sort of. If I change http://my.server.ip:31400/web to http://my.server.ip:32400/web … Plex does show up, however, it only shows up with my local media server (the one on my Macbook). It’s no longer connected to my seedbox (QuickBox) Plex.

Now, I did remove my seedbox (QuickBox) server from Plex web settings / devices about an hour ago hoping that it would help fix my issues connecting but obviously not. Prior to my removing it from settings / devices … the server would typically show up under settings but it had a really hard time connecting to my Roku Stick (which always worked perfectly before I manually updated Plex on my seedbox late last night per this thread) and when it did, it wasn’t transcoding (Cannot access this file. Make sure your system has permission to access the file or something).

I’m on Debian 8. The only other thing I can think of is that there were updates to several packages… php, openssh, etc. that I pulled down via apt-get update && upgrade over the past day or two. I’ve also been updating QuickBox via the QB dashboard (“Check for Updates”) probably daily for the last week or so keeping fresh with all the new changes. I don’t know if one of these things inadvertently screwed something up?

Pulling my hair out, I just want to get Plex back up and running again as this is one of the main reasons I even pay for a seedbox, as well as being the only reason I even have a Roku. Sorry if I screwed something up on my end? But I’m not a total moron when it comes to this stuff and all the ‘usual suspects’ or fixes are not working. I really love QuickBox otherwise and surely appreciate the help.


#16

Also, FWIW … I did run all of those manual upgrade commands again an hour or two ago before posting on here just to try and reinstall the latest update and see if that would reset things back to normal - but it didn’t help. I did notice that it didn’t ask me this time if I wanted to keep my old config like it did the first time I ran it last night.

And while digging around trying to fix this issue myself this afternoon, I also noticed that under /etc/systemd/system … there only exists “plexmediaserver.service.prev”. I’m pretty sure it wants a “plexmediaserver.service”. So I backed it up and renamed it to “plexmediaserver.service” and restarted the server but this also didn’t seem to help. Though I just looked and its now back to “plexmediaserver.service.prev”. I’m not sure if this was from the last time I reinstalled the latest PMS via wget and dpkg or if something else is forcing it or renaming it to *.prev?


#17

Great, thanks for the thorough feedback.

Let’s try a few things.

Have you attempted to follow this guide:

Additionally, what is the output of ls -l /etc/apache2/sites-enabled/. Does it show plex.conf as a listed configuration.

Ah, ok… could you try this for me real quick also:

systemctl daemon-reload
update-rc.d plexmediaserver remove
service plexmediaserver stop
systemctl enable plexmediaserver.service
systemctl stop plexmediaserver.service
systemctl start plexmediaserver.service

I meant to also comment on the plexmediaserver.service.prev file. This is in fact changed by plex on the update. However, you can leave it labeled as such due to Plex being systemd compatible in newer versions on it’s own.

It is loaded from…

/lib/systemd/system/plexmediaserver.service

Just going to go through every possible scenario till we hit the magic button.


#18

It sounds like your reverse proxy is broken. Can you paste the output of:

cat /etc/apache2/sites-enabled/plex.conf for us to examine?


#19

OK, so ls -l /etc/apache2/sites-enabled/ outputs -

total 20K
-rw-r–r-- 1 root root 1.3K Jul 24 19:27 aliases-seedbox.conf
-rw-r–r-- 1 root root 1.3K Jul 24 19:27 aliases-seedbox.conf.orig
-rw-r–r-- 1 root root 1.6K Jul 1 20:14 default-ssl.conf
-rw-r–r-- 1 root root 116 Jul 1 20:14 fileshare.conf
-rw-r–r-- 1 www-data www-data 0 Jul 1 21:01 plex.conf
-rw-r–r-- 1 root root 425 Jul 20 15:01 xxxx.console.conf

I did have remote access enabled before …back when my QuickBox server was actually showing up under my servers. But it doesn’t even show up any longer, so there’s not a whole lot I can do there now. I did try going to http://my.server.ip:31400/web/ on a different browser just to be safe but no dice.

I also ran all of those systemctl commands you gave but no change. Still nada on http://my.server.ip:31400/web/ and there’s no unclaimed servers or anything showing up when I login to plex.tv myself (under 32400, etc).

I went back into /etc/systemd/system after running those systemctl commands and there still only exists a plexmediaserver.service.prev … no plexmediaserver.service


#20

cat /etc/apache2/sites-enabled/plex.conf gives me nothing as far as output … ?


#21

If that file is empty, you will need to add this. As @liara suggests… this could be why it’s not working. Not sure why that file would be blank. Here is the code to add.

Replace PUBLICIP with your server IP and then service apache2 restart

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
<VirtualHost *:31400>
  ProxyRequests Off
  ProxyPreserveHost On
  <Proxy *>
    AddDefaultCharset Off
    Order deny,allow
    Allow from all
    AuthType Digest
    AuthName "rutorrent"
    AuthUserFile '/etc/htpasswd'
    Require valid-user
  </Proxy>
  ProxyPass / http://PUBLICIP:32400/
  ProxyPassReverse / http://PUBLICIP:32400/
</VirtualHost>
<IfModule mod_proxy.c>
    Listen 31400
</IfModule>