SCGI or RPC configuration to use sickrage

rpc
scgi
sickrage

#1

I would like to connect an external sickrage to rtorrent to manage/download series.
When I configure the torrent server on sickrage, it ask me “URL to your rTorrent client (e.g. scgi://localhost:5000
or https://localhost/rutorrent/plugins/httprpc/action.php)”, I trying scgi://mywanip:5000, https://mywanip/rutorrent/plugins/httprpc/action.php and scgi://mywanip:33503 but nothing works.

Error message : Error: Unable to connect to rTorrent

Is somebody can help me ? What’s the correct URL to type ?


Connect Quickbox rtorrent from distant Sickrage
#2

Hey there @Eikichi,

SickRage will be an official included package in an upcoming release, possibly by this weekend… in the meantime…

You need to assign the proper SCGI port to your settings in order to connect. You can find this within your /home/$USER/.rtorrent.rc file.

Just type:
Replace $USER with your actual username

cat /home/$USER/.rtorrent.rc

Look for the following:
Replace XXXXX with your actual scgi port number

scgi_port = localhost:XXXXX


Mylar - Not another RPC mount issue
#3

Hi JMSolo,

Thanks for the answer but I’ve already check it, in my .torrent.rc :

scgi_port = localhost:33503

In my virtualhost :

<VirtualHost *:80>
DocumentRoot “/srv/rutorrent/home”
<Directory “/srv/rutorrent/home/”>
Options Indexes FollowSymLinks
AllowOverride All AuthConfig
Order allow,deny
Allow from all
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd’
Require valid-user

SCGIMount /admin 127.0.0.1:33503

<VirtualHost *:443>
Options +Indexes +MultiViews +FollowSymLinks
SSLEngine on
DocumentRoot “/srv/rutorrent/home”
<Directory “/srv/rutorrent/home/”>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride All AuthConfig
Order allow,deny
Allow from all
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd’
Require valid-user

SSLEngine on
SSLProtocol all -SSLv2
SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
SetEnvIf User-Agent “.MSIE.” nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
SCGIMount /admin 127.0.0.1:33503

SCGIMount /admin 127.0.0.1:33503

In /srv/rutorrent/conf/config.php :

$scgi_port = 5000;
$scgi_host = “127.0.0.1”;

I’ve tried to change 5000 for 33503, like in apache and .rtorrent.rc conf, but it stille doesn’t work.

Note that my sickrage is not located on the same public and private network. Sickrage is on a online.net server and rutorrent on liteserver.nl VPS.

So, must I change something to be able to join rutorrent via SCGI from another network ?
Maybe changing localhost/127.0.0.1 by sickrage’s IP ?

When I do a ss -l, I can see that my server listen on 33503’s port only for 127.0.0.1

Netid State Recv-Q Send-Q Local Address:Port Peer Address:Port
tcp LISTEN 0 0 127.0.0.1:33503 :

I’m not at eas with the SCGI …
Note that it is the default configuration from QuickBox installation.

Sorry if my english is not always clear :slight_smile:


#4

You only need to pay attention to the .rc file I mentioned… it will be exactly the same in all other locations for your particular user.

I am fairly certain that SickRage will only listen for connections on the same network. As you see, your SCGI port is only going to be mounted and accessed via localhost. I have never attempted to connect remotely to SickRage.

I am going to have to say that this is not within the support scope of QuickBox as it is not an officially supported means of use. When and if I have time, I may seek an answer to this. Until then, you are on your own.

Don’t let this discourage you though, it is quite possible someone else may have the know-how on this. :slight_smile:


#5

Thanks, I will continue to seach and let you know if I found something.

Solution is maybe httprpc …


#6

Found with httrpc :

So, with the QuickBox default configuration :

rTorrent host:port:http://your-rtorrent-server-IP/your-rtorrent-user/RPC2
Http Authentication: Digest
rTorrent username:your-rtorrent-user
rTorrent password:your-rtorrent-user-password


How connect ruTorrent in SickRage
BTSync Folder Permissions
#7

Sweet find @Eikichi!

I will add this to a Wiki entry by the end of today to help out anyone else that encounters this.


#8

@Eikichi thanks … your settings working for me as well :smiley: