Plex not working after upgrade

When I try to enable Plex from the control panel it just goes back to disabled. In addition rutorrent is now telling me the disk is full despite having 2 TB available.

Edit: rutorrent is also down. Seems like nothing started up after the post-install reboot?

What OS and Release are you currently running QuickBox on? Also, verify if you are on an OVH/SYS server as this will help narrow down potential problems.

Additionally, what version are your upgrading from? If it was a version prior to 2.4, you will need to follow a few items here: QuickBox v2.4 Released

Yes I am on an OVH server. I am working on the rest and will report back. I am using Debian 8 and the upgrade was from prior to version 2.4 I forgot what version exactly, sorry

Ok I tried what you said and I got rutorrent to stop saying that the disk is full but Plex still refuses to connect

When you say Plex refuses to connect. Is this in regards to not being able to start a remote connection?

If this is the case, please read the following Wiki:

That’s the first thing I tried. When I try to connect the plex server from the console its is actively refusing the connection.

What is the output of systemctl status plexmediaserver

plexmediaserver.service - LSB: Plex Media Server
Loaded: loaded (/etc/init.d/plexmediaserver)
Active: active (exited) since Thu 2016-07-28 06:45:37 EDT; 6h ago
Process: 787 ExecStart=/etc/init.d/plexmediaserver start (code=exited, status=0/SUCCESS)

Ok… and when you navigate to http://yourserverip:31400/web/ can you login? That statement says Plex is indeed running.

I am not sure what you mean by:

Refused to connect

Do service apache2 restart

refused to connect

Will you send me your server login details through PM as I have little to work with. I can see what it is first hand.

I have logged into your server and can see that you are running default OVH kernel with grsec compiled. We have a very bold notice within our Readme that these kernels do not work well with these types of solutions/custom panels.

###Quick Advisory Notice(s) on QuickBox

:rotating_light: Heads Up!

grsec is built into OVH’s custom kernel and it absolutely wrecks havoc when using these panels where we depend on the ability for one user (www-data) to see the processes of another running user ($username).

This can be seen clearly by using a task manager such as h/top.

With grsec enabled you can only see the processes owned by your user unless you run htop as root. As such, it is highly recommended to use the stock kernel for your distribution or at the very least installing an OVH kernel that is not compiled with grsec

If you are using So You Start (SYS) as a host, you should opt to use the distribution kernel. You will see this as a checkbox option when installing your server.

I am going to update your kernel for you and put you on something without grsec. Your server will reboot within the next 5 minutes… it’s just me updating your system :slight_smile:

Message sent

You. Are. Awesome!

Did youfigure out what the problem was?

The solution above outlines part of the problem. The other half was to update your Plex with this method:

mkdir -p plex-tmp
mv plexmediaserver_*.deb plex-tmp/plexmediaserver_*.deb
cd plex-tmp
dpkg -i plexmediaserver_*.deb
rm -rf plex-tmp
service plexmediaserver restart

###Archived version can be found here.

wget -q
mkdir -p plex-tmp
mv plexmediaserver_*.deb plex-tmp/plexmediaserver_*.deb
cd plex-tmp
dpkg -i plexmediaserver_*.deb
rm -rf plex-tmp
service plexmediaserver restart

Why would I need an archived version?

Plex recently released an update that interferes with how we reverse proxy plex to be connectable without the need of an ssh tunnel. In the meantime, you may opt to use this stable archive version … at least until Plex resolves this issue and a proper update is released… at which point you can type upgradePlex to update to the latest version. At any time, you may additionally fall back to this version.

This then set your plex to read from the proper systemd template. Additionally, your plex.conf template was blank. I am assuming that after the update it imported the template from the repo, but for some reason imported it as blank. So it was a matter of the proxy not reading the forward.

Hello, i’m having problems to set up Plex too

[quote=systemctl status plexmediaserver]
● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
Active: failed (Result: start-limit) since Sat 2016-07-30 09:29:04 CEST; 3min 9s ago
Process: 20172 ExecStartPre=/bin/sh -c /usr/bin/test -d “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” || / bin/mkdir -p “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” (code=exited, status=1/FAILURE)

Jul 30 09:28:59 DZGD1464 systemd[1]: Failed to start Plex Media Server for Linux.
Jul 30 09:28:59 DZGD1464 systemd[1]: Unit plexmediaserver.service entered failed state. [/quote]

@Grayman, we will need more details before we can help.

  1. What OS are you on
  2. What version of QuickBox
  3. Is this after an update… etc

Debian 8.5 (jessie), quickbox version 2.4.4.
Had to do a fresh installation due hard drive failure, with previous version everything was working fine