How connect ruTorrent in SickRage

sickrage

#1

Hello all,

First, thank to the QuickBox team for this awesome tool !

After installing my seedbox, I have tried to connect SickRage with rutorrent… I have tried many things, but SickRage always said me he is unable to connect with rutorrent.

Someone know how I can connect ruttorrent with SickRage ?

Thanks !


#2

Check out the solution that @Eikichi provided in the following post.


#3

Hello,

I have already tried this… :confused:


#4

Could you show what you currently have for your settings, then we’ll have some grounds to work off of.


#5

Yes :

When I go to https://x.x.x.x/user/RPC2 I have an error :

Forbidden

You don’t have permission to access /user/RPC2
on this server.

Apache/2.4.10 (Debian) Server at X.X.X.X Port 443


Connect Quickbox rtorrent from distant Sickrage
#6

Technically that is normal that you will see forbidden… it is meant to pass the port only, there is nothing to view in terms of web browsers.

Try the field for your host port to only use /user/RPC2 instead of the full IP string. That is a setting I have in my personal as well and there are no issues.

…and just to verify… what version of QuickBox are you using?


#7

What is the good port ? Actually I don’t have any port…

For the moment I try to configure with : https://123.123.1231.123/user/RPC2

Do you mean the correct URL is https://123.123.123.123:XX/user/RPC2 ?

I use the v2.3.4

Thanks


#8

No, use it just as I stated with : /youruser/RPC2 (nothing else in front of it)


Mylar - Not another RPC mount issue
#9

Oh yes… Sorry !

Just tried and nothing new :frowning:


#10

Ok, then try to use the scgi port instead.

scgi://localhost:XXXXXX

You can find your scgi port in your /home/username/.rtorrent.rc

It will be the line labeled : scgi_port = localhost:XXXXXX

Typically the RPC settings are better for remote settings… scgi for localhost is preferable.


#11

Thanks for your help, but unfortunately… nothing new. This configuration seems to be complicated :smile:


#12

GOOD NEWS ! :smile:

I just tried with this URL :

https://localhost/rutorrent/plugins/httprpc/action.php

And it’s worked ! Thank you again JMSolo !


#13

Not sure why this was such a complicated thing for you :slight_smile:

The settings were pretty forward. I think when you tried scgi port you forgot to enable SSL.

At any rate, I am glad it is working for you now!


#14

To use http://localhost/user/RPC2 you must have a different RPC number configured on each users in /srv/rutorrent/config/users/config.php (not sure about the file name).
So if you have 3 users you must use RPC2 for the first user, RPC3 for the second and RPC4 for the third.
For user3 the URL become http://localhost/user/RPC4.

Usefull for multiple users.

I can do screenshots tomorrow if needed (for your howto JMSolo)


#15

Sounds good. I do plan on putting this together now that I have some other pages/tasks out of the way.


#16

First, change each /srv/rutorrent/conf/users//config.php to have a different $XMLRPCMountPoint per user, you can enter anything you want, by defaut they’re all configured with RPC2.

Example with my user dl, I changed for RPC3 :

So, in sickrage you change URL with the correct user and $XMLRPCMountPoint :