Error when Update Plex


#1

Hi,

i saw that a new version of plex is ready for my server but when i try to update it via ssh (upgradePlex) i got this error : “ERROR: Unable to retrieve the URL needed for download (Query DISTRO: ubuntu, BUILD: linux-ubuntu-x86_64)” so if someone can help me with that it will be very cool.


#2

I can confirm this, it’s the exact same thing here.

I think plex changed something on their servers or they might have missed something.


#3

Confirming same here.


#4

Hello!

We have fixed this in the upcoming update. The issue was with a change in Plex’s Json feed. We’ve adjusted to match this change.


#5

Thanks Mischief. Any idea on a release time?


#6

We’re aiming for Friday, but it might be a little later on the weekend


#7

Hi Mischief,

Thanks for the reply and the info about the fix, hope to update soon :slight_smile:


#8

Great news you can now update plex without error :slight_smile:


#9

Hmmm… mines still erroring out. Says I’m on the latest commit…


#10

hey, run the updater (one the quickbox panel) then go to putty log in user type sudo su then type upgradePlex :slight_smile:


#11

Tried running the update via the Quickbox Panel) but got the following errors:

Pulling QuickBox Ecosystem ... 
fatal: could not read Username for 'hxxxs://github.com': No such device or address
quickbox_setup              :: fatal: could not read Username for 'hxxxs://github.com': No such device or address
quickbox_rutorrent          :: fatal: could not read Username for 'hxxx://github.com': No such device or address
quickbox_rutorrent-plugins  :: fatal: could not read Username for 'hxxxs://github.com': No such device or address
quickbox_packages           :: fatal: could not read Username for 'hxxxs://github.com': No such device or address
quickbox_dashboard          :: fatal: could not read Username for 'hxxxs://github.com': No such device or address
club-QuickBox               :: Already up-to-date.
Checking locks and adding if necessary ... 
Checking if cron services should be uninstalled and taking appropriate action ... 
Updating QuickBox System Commands & Packages ... 
Updating the useradd skeleton directories ... 
Updating mktorrent if necessary ... 
Checking apache aliases ... 
Updating the rutorrent directory ... 
Updating all rutorrent plugins ... 
Updating the QuickBox Dashboard ... 
Updating club-QuickBox ruTorrent Theme ... 
Updating the QuickBox Sudoers template ... 
Adjusting permissions ... 
[QuickBox] Seedbox & GUI Update Completed !

#12

hi,

try this solution : Error when attempting to update from v2.3.7 to v2.4.7


#13

I can confirm that the update works. Updated yesterday by clicking ‘RUN UPDATER’ on the dashboard, followed by sudo su in CLI to end with upgradePlex.


#14

Did that. Got the following error when I ran

bash upgradeQuickBox

upgradeQuickBox: line 1: syntax error near unexpected token `newline'
upgradeQuickBox: line 1: `<!DOCTYPE html>'

Also it says I’m running 2.4.9 at the “home” page


#15

sudo su
box update
box upgrade
upgradePlex


#16

Asking for username and password for github when I use

box upgrade

Username for 'https://github.com':
Password for 'https://github.com':
remote: Repository not found.
fatal: Authentication failed for 'https://github.com/QuickBox/quickbox_dashboard.git/'
Stopping at 'dashboard'; script returned non-zero status.

#17

Did you ever change to the new repository? Had to be almost 2 years ago now when stuff switched over. You should be on version 2.5.5.


#18

Yeah been trying to get to the new repo, but nothing linked so far has worked, including the link you just provided.


#19

because of the urls changing some time ago, i dont know how to get to the post with instructions because you’re right that link doesnt work. might have to see if one of the higher ups can pull something up for you.


closed #20

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.