Error when attempting to update from v2.3.7 to v2.4.7

not-a-bug
upgrade

#1

Hi all,

I receive the following error when I attempt to update from 2.3.7 via the dashboard:

Pulling QuickBox Ecosystem …
fatal: could not read Username for ‘https://github.com’: No such device or address
quickbox_setup :: fatal: could not read Username for ‘https://github.com’: No such device or address
quickbox_rutorrent :: fatal: could not read Username for ‘https://github.com’: No such device or address
quickbox_rutorrent-plugins :: fatal: could not read Username for ‘https://github.com’: No such device or address
quickbox_packages :: fatal: could not read Username for ‘https://github.com’: No such device or address
quickbox_dashboard :: fatal: could not read Username for ‘https://github.com’: No such device or address
Checking for quotas and adding lock file if necessary …

Does anyone have any idea how I can fix this please?

Thanks for any help


#2

Hey there @dough.

Updating from versions previous to v2.4 is a massive overhaul and takes another command that is more of an easter-egg. It’s our legacy upgrade. part of the issue you will have is due to the fact that we use our own git now rather than relying on third-party solutions.

Run the commands below as root. You can become root from your sudo account easily by typing sudo su

Do the following to get started with your upgrade:

cd
wget -O upgradeQuickBox https://lab.quickbox.io/QuickBox/quickbox_packages/raw/master/system/upgradeQuickBox
bash upgradeQuickBox

The above will activate the new EcoSystem on your server, it basically sets up a local repository that makes updating QuickBox in the future much easier and also allows a fallback in the offchance that anything gets set improperly.

Next, you will need to run a quick update of your system by typing the following:

cd
bash QuickBox/packages/system/updateQuickBox

Next you will need to adjust your directories structure to match the new structure for QuickBox’s apache configuration. This structure is referrencing the /home/USERNAME/torrents as we now separate deluge from rtorrent for easier organization between the two.

This is done for you by typing adjust-user-directory. You will next need to manually select ‘Save to…’ on your torrents in ruTorrent to save them to the new /home/Username/torrents/rtorrent directory.

###Pro Tip
Pressing Ctrl+A in ruTorrent will select all torrents simaltaneaously.

For more about this, check out this post:

With these steps done, you can do one final command to ensure that you are completely caught up and running a stable v2.4.7 of QuickBox. That command is box upgrade. Just like that, you’re done. Not so hard! :smiley:


#3

I did all of these steps. It didnt worked. Im still on Version 2.3.7


#4

Honestly @RaymondSchnyder, if you followed the steps above, there is no way you would still be on v2.3.7. Please ensure that you have followed the steps outlined exactly.


#5

Why is it when i try running this command i get

       Username for 'https://github.com':

Do i need to signup for a github account?


#6

No, you do not. I would need to know more information however.

  1. Is your issue exactly the same as the one stated by @RaymondSchnyder?
  2. What version of QuickBox are you on?
  3. Have you followed the above method to upgrade if under 2.4

I can’t provide any clarity if you provide little to no information. I can say that we no longer use GitHub as we self-host our own gitlab for QuickBox now.


#7

I followed all the steps mentioned above. I fixxed it with a restart…


#8

Correct, more than likely it was just memcache and/or your browser caching. If it happens to where it looks like updates versioning doesn’t post… just type service apache2 restart and be sure to clear browser cache. System reboots aren’t normally needed.

Glad you got it sorted. :smiley:


#9

Hi JmSolo,

  1. The initial problem was the same as @dough
  2. I am running 2.3.7
  3. When i tried to upgrade via control panel i had the “could not read user name”
  4. So i followed the steps above and all was going well until i got to the “bash QuickBox/packages/system/updateQuickbox”
  5. I received this “Username for ‘https://github.com’:”
  6. I’m running Ubuntu 16.04 @ online.net

Thanks for all your help and seriously love this project.

If there is any more info needed let me know.


#10

You are running the wrong script for the upgrade. Note the code block above:

You will need to download from our lab the upgrade script and run it to begin the process for updating your systems to make use of the new gitlab.


#11

All of that seems to be running fine.
"[quickbox] Seedbox & GUI Update Completed !"

Ive done the

service apache2 restart

however it still says i’m on 2.3.7?

sorry for being such a newb :frowning:


#12

Confirm that you followed the steps above exactly.


#13

Step 1 -
Logged in as root
(completed, no issues)

Step 2 -
cd
wget -O upgradeQuickBox https://lab.quickbox.io/QuickBox/quickbox_packages/raw/master/system/upgradeQuickBox
bash upgradeQuickBox

(completed, no issues)

Step 3 -
cd
bach Quickbox/packages/system/updateQuickbox
(failed, Username for ‘https://github.com’:

stuck again here …

Am i missing something between step 2 and 3?


#14

Yes, something is amiss as you should not be hitting failed, Username for 'https://github.com': as none of our commands use github anymore.

If you like, you can submit your server credentials to me in PM and I can login and take a look at this for you.


#15

Thanks @JMSolo
I do have to fly to work… I’ll pm soon as i get home.


#16

@JMSolo

I just want to point I am having the same problem of being asked for github username (ofc did server restart and downloaded new upgrade script too).
(Running QB 2.3.7 on Ubuntu 16.04 x64)
Thanks.

Edit: just wanted to note that following this => QuickBox v2.4 Released!
After copying new repo files the command “updateQuickBox” worked, and I was able to upgrade to 2.4.7.

Only remaining issue is the http/apache server is denying me access to dashboard now (everything else, plex, ssh, ftp… etc) is working.


#17

Once you run the upgrade, run the command box upgrade. This will reset any faulty (leftover) settings that you have from any previous versions.