When installed picked /home/ but would like to change to /?


#1

Sorry if the topic is a little unclear, couldn’t think of a better way of phrasing it offhand.

When I installed and did the initial setup for quickbox, I chose the /home/user option as opposed to /. I’m assuming this dictates the visibility of things like rutorrent to the rest of the system?

I ask because I’ve got nfs shares mounted under /mnt, but rutorrent is not able to see /mnt to save new torrents there.

If this is infact due to the choice of /home instead of /, how do I go about changing it?


#2

better off reinstalling os and script trust me lol i tried this before was a pain there is a lot of settings that have to change and when you run update you have to change them again
but up to you.


#3

hah ok thanks. I’m running it in a VM, and I’m kicking myself for not taking a snapshot of the freshly installed OS now :slight_smile:


#4

I do know your pain at least you did not make this mistake on a server that has been used… lol i will say after people have things downloading things starting over is a pain… people do not like data loss…


#5

wait befor you do reinstall hold on


#6

Hey there @snapek!

Well, technically, when you chose an option in the beginning this is solely for telling QuickBox which mount point to use for quotas in your system.

You can mount this back to /(root) by doing the following:

quotaoff -a
service quota stop
mount -o remount /
quotacheck -auMF vfsv1
quotaon -uv /
service quota start

However, we will first need to adjust your fstab and verify that /(root) mount should be used.

So if you could do this, what are the results for the following:

lsblk

as well as

cat /etc/fstab

Once we have those details out of the way… we can work on getting you back in order.


#7

rutorrent is set up per user dir so having it go outside the user dir is gonna be lot of work may i ask why you want to do it this way?


#8

Ah, that could present a problem. I wonder what @liara would have to say about this when she is available?


#9

@JMSolo
now you see why i said wait for him? lol i had to read a few times before i understood what user wanted XD
but idk that reinstall or even the changing mount point would help. unless he changed mount point to the share drive.


#10

Well, we would have to change the mount point to the nfs /mnt that is being shared… but the problem would be in that all torrents are being saved by rtorrent/deluge to /home/_user_/torrents. So, yeah… there may need to be a re-tooling of where QuickBox stores it’s data on completed downloads… then quotas just read from there.

This would more than likely be a custom job. I know I will be corrected if I am wrong though.


#11

This is an adaptation of how I use rutorrent/rtorrent normally on my NAS. It’s also a single-user setup currently.

Traditionally I’ve had my session, watch and torrent paths in /home/user but the mounts for storage in /mnt.

I was turned on to quickbox and wanted to give it a try, so I farmed out /mnt/* to NFS shares so the quickbox VM could access them and I could migrate my torrents and activity over, set up quickbox in a VM and mounted //server/mnt to /mnt and copied my session folder over. That all has worked fine (albeit a bit slower / higher ram use than expected but I’ll investigate that later), but the only issue remaining is that rutorrent can’t see /mnt/ to add a new torrent to.

That said, rtorrent can see /mnt just fine, as it’s able to open and seed all my existing torrents from /mnt/… so I know it’s an rutorrent issue. I’ve checked the config.php for /srv/rutorrent and it’s showing the top level directory is “/”.


#12

Not necessarily - these things can be dictated by global permissions as well.

I know the filemanager’s top level is controlled by your file manager config and rutorrent’s top level is controlled in your rutorrent config (/srv/rutorrent/conf/users/${username}/config.php) eg:

  $topDirectory = '/home/Data/';

I’ve had a real bitch of a time getting this to work properly in reality though and the rutorrent file browsing dialogs don’t always play nice even, if you change topDirectory=’/’;

Edit: If you enter the path manually it should work – using the dialog boxes I always get reset back to the default download directory if I try to browse outside my home directory. It’s also possible this is a bug with rutorrent that I intend to give an update to today


#13

I did try entering the path manually for /mnt/path/to/store but it kept reverting to /home/user. That said, I had only edited the global config.php it seems, and not the user-specific one. I’ve edited that and I am now successfully able to view /mnt (though I do have to manually type the path and click … to view, but that’s expected behavior with rutorrent, as stated).

So all in all it’s working now, all boiled down to editing topleveldir for the user specific config.php.

edit - just want to say I LOVE this project, and am very impressed with the speed and quality of support responses. You’ve won me over already, happy to be here and help test things out :slight_smile:

edit2 - off topic, but I should note that I was migrating in ~2600 torrents and the default setup having both rpc and httprpc plugins enabled in rutorrent was causing it to time out. I ended up having to disable httprpc and left rpc enabled, and was able to get things responsive on the webui front.


#14

Fantastic! We’ll set this as resolved off of @liara’s response.

…and thanks for the compliments! Keeps us motivated for sure!


#15

Sorry to re-open the discussion again, but rutorrent is throwing me disk space errors and I’m unable to add new torrents.

I’ve confirmed (well, pretty sure at least) it’s not a mount / nfs issue, as I can touch/rm files on the /mnt/… path as detailed above.

I can tell rutorrent to add a torrent to /mnt/downloads/ but it doesn’t show up in the client. I also get the “Warning! The disk is full. rTorrent may not run correctly…” etc bubble in the bottom left. I disabled the diskspace plugin, but no change. I tried both / and /mnt as topdir in both the global and user specific configs, no change.

I did follow your steps above for the quota path changes, so I’m wondering if I’ve overlooked the obvious as to why it’s reporting 0 bytes free. Also as requested output of lsblc and fstab


#16

idk if this has been answered but have you setdisk?


#17

I had earlier, but did so again just now to be sure. I also had just happened to restart the apache service, and rutorrent is no longer throwing disk space warnings, but still isn’t adding new torrents.

If I mouse-over the disk space icon in the bottom left, it shows as 100% used. I gave it 200TB quota and it’s showing 200 TB (well it reads as 199 TB) used.

On a likely related note the dashboard disk space display is also nonfunctional and hasn’t worked since I installed.


#18

did you change the mount point from / to /home?
your readout shows / so if you mounted home for quota it would be a bit of a pain and not show correctly


#19

Yeah, this is where I mentioned having to re-tool parts of QuickBox. The Disk Widget is built with either a /(root) mount or /home mount in mind. In theory I could customize the php for you to have that point to your proper mount / storage volume. The same goes for your fstab… you may have to adjust that like the following:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# 
/dev/mapper/venamis--vg-root / ext4 defaults 0 1

# /boot was on /dev/sda1 during installation
UUID=5ab248e2-a676-4626-a5c7-1369c2af1553 /boot ext2 defaults 0 2
/dev/mapper/venamis--vg-swap_1 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
10.0.0.15:/mnt /mnt nfs usrquota,errors=remount-ro vers=3 0 0

Perhaps that would work… and of course resetting the quota with the command

quotaoff -a
service quota stop
mount -o remount /mnt
quotacheck -auMF vfsv1
quotaon -uv /mnt
service quota start

This is just theory… so we’ll have to keep chipping away at this until we have you settled.

You could also try adding this to your /srv/rutorrent/home/widgets directory. Remove the other disk_data.php and rename this to that accordingly.

disk_data-mnt.php.txt (5.5 KB)


#20

@JMSolo just a heads up he reached his post limit so he can not reply, Via post