Update autodl IRSSI


I’m having problems with my Autodl IRSSI, and according to this


i need to update, but how can i do it?


Hey there @Cruzz, try running the following (replacing USERNAMEHERE with your own username)
Copy and paste as root preferably


sed -i 's/$Net::SSLeay::VERSION >= 1.86/$Net::SSLeay::VERSION >= 1.84/g' /home/$USERNAME/.irssi/scripts/AutodlIrssi/SslSocket.pm
service irssi@$USERNAME restart


Unfortunately it did not solve my problem. I’m still on AutoDL-Irssi v2.6.0, and can’t update. When pressing update i’m getting the following errors

Could not check for autodl updates
Could not check for tracker updates

The issue i’m trying to solve by updating is that i’m getting a Could not parse HTTP response header everytime an entry is made in the IRC channel. Due to that my autodl is not working


Could you additionally try:


sed -i 's/my $res = Net::SSLeay::write($self->{ssl}, $data);/my $res = Net::SSLeay::ssl_write_all($self->{ssl}, $data);/g' /home/$USERNAME/.irssi/scripts/AutodlIrssi/SslSocket.pm
sed -i 's/my $got = Net::SSLeay::read($self->{ssl}, $len);/my $got = Net::SSLeay::ssl_read_all($self->{ssl}, $len);/g' /home/$USERNAME/.irssi/scripts/AutodlIrssi/SslSocket.pm

service irssi@$USERNAME restart

I am also experiencing this issue on my server (QuickBox Community). Did any of the scripts below work for you? No luck for me…

I could not get the above scripts to work, so i tried to do a reinstall using the following.

cd ~/.irssi/scripts
curl -sL http://git.io/vlcND | grep -Po ‘(?<=“browser_download_url”: ")(.*-v[\d.]+.zip)’ | xargs wget --quiet -O autodl-irssi.zip
unzip -o autodl-irssi.zip
rm autodl-irssi.zip
cp autodl-irssi.pl autorun/
mkdir -p ~/.autodl
touch ~/.autodl/autodl.cfg

The above is taken from https://autodl-community.github.io/autodl-irssi/installation/

Before i used the above, i took a backup of the “Autodl.cfg”, but i didn’t have to reload it, as it didn’t get overwritten

Thanks mate - this worked for me.