Sonarr Installation Guide

sonarr

#1

Hi Guys

I’m wondering if someone can help point me in the direction of a guide for installing Sonarr?

I followed this tutorial http://www.htpcbeginner.com/install-nzbdrone-on-ubuntu/, but when i quit out of SSH Sonarr crashes. I even added the config file so it should launch on reboot, but it doesn’t seem to work. I essentially have to launch Sonarr everytime within the SSH.

Thanks


#2

Hold off on your installation as today, I am happy to announce I will be pushing an official QuickBox package of Sonarr.

You can follow along on the quickbox_setup repo:
https://github.com/QuickBox/quickbox_setup/tree/sonarr

You can view Dashboard inclusion progress here:
https://github.com/QuickBox/quickbox_dashboard/tree/sonarr


#3

Cool, so just update from the dashboard when its released and sonarr will be available and viewable on the dashboard?

Thanks


#4

That is 100% correct. :slight_smile:


#5

The F…! This is awesome :slight_smile:


#6

You can now run the update from your dashboards and Sonarr will show as an install-able package. The version bump will follow here within the next hour along with an announcement and changelog adjustments.


#7

So sonarr is installable from the dashboard, but I might be missing the obvious as to how to get to the sonarr interface itself. Should there be a link from the dashboard, or documentation on it that I overlooked?

edit - oh I see that sonarr is installed and set to ON in the service controller, but the service itself still shows as disabled.


#8

just wait for it as it will show up in the menu left once the service is running.
Might try Reload Services after popping the service controllers…

It popped on and showed after a few secs and a browser reload :slight_smile:

http://i.imgur.com/G4nAe1a.jpg


#9

Are you running Debian by chance?


#10

Yes I am running debian 8


#11

Then what you my friend have is a case of the “Deebs” it’s nothing epic and not contagious… thanks to @globber I was able to narrow this issue down… and it turns out it is Debian doesn’t like the official mono repository.

So, here is what you can do…

  1. The easy way
  • Update QuickBox from your dashboard after you uninstall Sonarr. Then reinstall Sonarr and the service should come online after a minute (the cron needs to pick it up to initiate the service first… this might be your case right now)
  1. The more complicated way
  • Follow the instructions below:
rm /etc/apt/sources.list.d/mono-xamarin.list
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
    echo "deb http://debian.meebey.net/pkg-mono ./" | sudo tee /etc/apt/sources.list.d/mono-meeby.list
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FDA5DFFC
  echo "deb https://apt.sonarr.tv/ master main" | sudo tee -a /etc/apt/sources.list.d/sonarr.list
sudo apt-get -y update
sudo apt-get install -y mono-devel
sudo apt-get install -y nzbdrone
sudo rm /etc/apt/sources.list.d/sonarr.list

#12

Ahaa you made me immune to this eh :wink:
Just joking…and thanks for the explanation why mine is working and his isn´t!


#13

I guess I did spare you the fine details didn’t I? Can’t un-see the “Deebs” @Globber


#14

I think there may be a mismatch in mono-devel versions. I had to adjust your steps a bit, and it still doesn’t look like it’s starting up.

I had to -

  1. update quickbox from dashboard
  2. uninstalled/reinstall sonarr from dashboard
  3. apt-get install mono-devel from ssh
  4. THEN add the sonarr.tv repo and install nzbdrone.

But now if I go to do an apt-get upgrade it’s throwing dependency issues re: mono-devel and holding back packages.


#15

Did you remove the old source for the mono-xamarin.list?

Which I guess… would be sort of important to include in the installer… in the event it exists on the system. I’ll do an if [ this.list] find and rm function here in a few.


#16

Yeah I did.

After my last reply I ran apt-get install mono-devel again to see if it would kick in those packages being held back, it installed stuff from both repo’s. I then was able to run apt-get upgrade without it giving me dependency errors.

Perhaps there should have been and apt-get purge in there somewhere in relation to clearing out the old mono-devel before replacing it?

I’ve restarted the service and am now waiting to see if it shows as enabled/active and I get the dashboard entry.

edit - woo, the sonarr service is green and enabled now at least. refreshed the page to get the dashboard menu entry for it.


#17

:thumbsup:

Your perhaps is spot on kind sir. I will throw in an apt purge along with an autoremove and clean. Updating this in the next 15 minutes.


#18

So now that i’ve got sonarr up and running, any tips on getting it to pass torrents along to rtorrent?

What is the typical settings page for rtorrent to look like? I’ve tried the server IP, with /RPC and port 80 or 8080 and provided the username and password for the account, but neither works. Port 8080 gives connection refused, and port 80 “Unknown exception: Error writing headers” which googling leads me to believe is mono telling me it is having issues authenticating?


#19

See if this solution works for you:


#20

Hmm, that seems to be a step closer as now I get an unauthorized response when testing. I’ve confirmed the user/pass is correct though.