SABNZBd installed BUT red dot in Service Control Center


#1

Hi to all,

I have tried to install SABNZBd first via the Dashboard and then again via terminal as root user with the command box install sabnzbd. Both times i tried SABNZBd shows up in the Service Control Center but with a red dot. I clicked on refresh but nothing. SABNZBd seems to be accesible from the browser but it cant complete a download since it always spits out errors. Something like it cant find a par2 file etc… I also did a systemctl status [email protected] and the output was:

mantax:~# systemctl status [email protected][email protected] - sabnzbd
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2017-01-14 14:51:17 EET; 2h 15min ago
  Process: 2444 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
  Process: 2450 ExecStart=/usr/bin/screen -f -a -d -m -S sabnzbd python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:65080 --https 65443 (code=exited, status=0/SUCCESS)
 Main PID: 2454 (screen)
   CGroup: /system.slice/system-sabnzbd.slice/[email protected]
           ├─2454 /usr/bin/SCREEN -f -a -d -m -S sabnzbd python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:65080 --https 65443
           └─2455 python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:65080 --https 65443

Jan 14 14:51:17 mantax systemd[1]: Stopped sabnzbd.
Jan 14 14:51:17 mantax systemd[1]: [email protected]: Unit entered failed state.
Jan 14 14:51:17 mantax systemd[1]: [email protected]: Failed with result 'exit-code'.
Jan 14 14:51:17 mantax systemd[1]: Starting sabnzbd...
Jan 14 14:51:17 mantax systemd[1]: Started sabnzbd.
mantax:~# 

Any clue what the problem here is?

Thanks in advance

George


#2

Can you issue a stop and start once more and see if this gets it fired up on your dashboard. You can do so with the following:

systemctl stop [email protected]
systemctl start [email protected]


#3

I issued both above commands and i got the following output in the terminal:

[email protected] - sabnzbd
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset:
   Active: active (running) since Sun 2017-01-15 10:56:35 EET; 1min 11s ago
  Process: 26825 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
  Process: 26830 ExecStart=/usr/bin/screen -f -a -d -m -S sabnzbd python SABnzbd
 Main PID: 26832 (screen)
   CGroup: /system.slice/system-sabnzbd.slice/[email protected]
           ├─26832 /usr/bin/SCREEN -f -a -d -m -S sabnzbd python SABnzbd/SABnzbd
           └─26833 python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:6508

Jan 15 10:56:35 mantax systemd[1]: Starting sabnzbd...
Jan 15 10:56:35 mantax systemd[1]: Started sabnzbd.

As always it SEEMS that it is running correctly BUT the service appears in the Service Control Center again with a red dot. Also every time i login into SABNZBd there appears an error par2 “binary… NOT found!”. Here is a crop of a screenshot of it:

So this error is appearing every time i login into SABNZBd. Also for some reason SABNZBd spit out this error during downloading a file from the USENET. So i googled and found SOMETHING like a solution. I typed in the terminal:

which par2

And the output was:

bash: type: par2: not found

So after this i typed:

apt-get install par2

And again i issued the command “which par2” but this time the output was:

par2 is /usr/bin/par2

After this SABNZBd seemed to work. I downloaded a NZB file from the USENET. Its also got unpacked etc. I added a new NZB file to download. It worked and in the Quickbox Dashboard i saw that Download Graph spicked up and the Downloaded data info got updated corrctly. etc. The only problem now is that next to SABNZBd is still appearing the red dot. I tried to start and stop the service with:

systemctl stop [email protected]
systemctl start [email protected]

But again the red dot appears in the Service Control Center. I cleared the browser cache etc entered again in the Dashboard … again the red dot. To be clear SABNZBd IS working it just needed this extra apt-get install par2 command but seeing this red dot makes you always think that it is not working etc.

Thanks in advance

George


Issues with SABnzbd after install
#4

Thanks for reporting this to us @gmantakis. I will make time to look at this today. I am fairly certain it is a minor issue with the process that SAB should be reading to confirm if active or not.


#5

Fresh install, same 2 issues. Thanks for the par2 solution!


#6

Also had an issue with python SSL not installed as reported by sabnzbd. Ran the following and restarted:

sudo apt-get install python-openssl

Now the only thing to contend with is just the red status alert.


#7

Any update to the red status indicator?


#8

We will be working on this over the next few days. The current priority at the moment is releasing the new QuickBox website and addressing the inclusion of better documentation. We will post an official update once a patch for this has been released.


#9

Hello,

Any updates on this? I tried debugging this, but I don’t know php that well.

I don’t understand why it starts working properly when sick rage is installed.

Thanks,


#10

My apologies. The real culprit is the absence of the python module python-cheetah. After installing it, everything is working as it should.


#11

Sabyenc is also missing. Run ‘pip install sabyenc --upgrade’ .