Rutorrent dashboard link missing


#1

I’m new to quickbox and have made a few customizations migrating to it from my old server. Initially there was an rutorrent dashboard menu link, but now it’s gone. All services are running and I can access it directly without any issue. Is there something I can check as to why it’s not showing?

Customizations/migrations I’ve made:

  • Moved rtorrent download location to my original structure (/home/user/rtorrent/data)
  • Added my own valid SSL cert
  • Copied over rutorrent settings for my user from old box
  • Changed SSHd port
  • Some TCP tuning tweaks

On a side note - moving the rtorrent download folder also broke the dashboard Downloads link for it. I did match the permissions and updated the apache symlink for the destination folder but I still get a Forbidden error when I try it.

If there are any logs or conf files I could upload to review, let me know. Thanks!


#2

Check out the aliases-seedbox.conf located at /etc/apache2/sites-enabled. You’ll be able to adjust your download directories/links under the given aliases Alias /USERNAME.rtorrent.downloads "/home/USERNAME/torrents/rtorrent/" and Alias /USERNAME.deluge.downloads "/home/USERNAME/torrents/deluge/".

As for the ruTorrent link missing. This little tidbit of code is what tells it to show:

<?php if (file_exists('/home/'.$username.'/.sessions/rtorrent.lock')) { ?>
    <li><a class="grayscale" href="/rutorrent" target="_blank"><img src="img/brands/rtorrent.png" class="brand-ico"> <span>ruTorrent</span></a></li>
<?php } ?>

If your .sessions/rtorrent.lock file is in a different location, or simply doesn’t exist, the menu link for ruTorrent will not appear. This section of code is located at /srv/rutorrent/home/inc/panel.menu.php. Be advised however that any adjustments made to these files will be overwritten on update.


#3

@JMSolo Thanks for the tips - you’re spot on. To avoid issues with updates, I opted to move my .sessions folder back and updated my .rtorrent.rc and the dashboard link came right back.

I also doublechecked aliases-seedbox.conf file, and I had modified the Directory entry, but not the Alias itself, duh… All’s good now :slight_smile: