PSA: Recent Plex updates cause reverse proxy breakage


#1

After running into strange issues with the recent round of Plex updates that Plex has been pushing, it has been determined that Plex has introduced something which causes reverse proxies not to function.

There is nothing we can do to fix this, this code must be fixed by Plex. It is uncertain if the change was intentional or accidental.

With that said, in order to setup Plex, you’ll have to use the tried and true SSH tunnel method again. Hopefully the Plex team will fix this and not leave it in the state it’s in.

More info


Plex not working after upgrade
Port for plex web url incorrect
Plex cannot find my new QB server
Can't Claim Plex Server or access outside network
Plex server missing?
Install Let's Encrypt on your seedbox
#2

If you manage to upgrade your plex, and find yourself with a borked access. Please keep in mind… creating an SSH tunnel does still work. You may additionally install over your current install an old (very old but stable) version of Plex. You can do so by following the guide below:

###Archived version can be found here.

wget -q https://lab.quickbox.io/QuickBox/quickbox_setup/raw/master/sources/plexmediaserver_0.9.17.3.2239-fe07491_amd64.deb
mkdir -p plex-tmp
mv plexmediaserver_*.deb plex-tmp/plexmediaserver_*.deb
cd plex-tmp
dpkg -i plexmediaserver_*.deb
..
rm -rf plex-tmp
service plexmediaserver restart

:bookmark: Pro Tip

After claiming your server with the archived version, you can then run upgradePlex and have the latest version without issue.


#3

@JMSolo, @liara . I have used shadowsocks to setup my plex for the first time and it also works as a VPN. I have used below script to install shadowsocks and the good thing is it didn’t break anything on my current setup which I have been using from last 1 month with regular updates to the quickbox script

wget --no-check-certificate https://raw.githubusercontent.com/teddysun/shadowsocks_install/master/shadowsocks-libev-debian.sh
chmod +x shadowsocks-libev-debian.sh
./shadowsocks-libev-debian.sh 2>&1 | tee shadowsocks-libev-debian.log

Source


#4

bumping (archived version updated to a more recent package)


#7