Can't Claim Plex Server or access outside network


#1

First I installed Plex from QB dashboard and went to login to setup server and server could not be found. I understand that is to recent update to plex and there’s this topic on it.

I did the install of old version and this worked to now allow me to setup my server. But now issue is I cannot claim it or access outside network. Exactly what this shows.

But as I said. I can click claim all i want and it keeps telling me to claim. I go under Remote access and can’t connect outside network. I did try that ssh tunnel but that did not work either.

Also, from that first topic that installs old version of plex. It says to run ‘upgradePlex’ to update to latest version as will now work. I try that command in ssh and am told does not exist. What am I missing on that. Thanks for any help.


#2

Sometimes the browser just screws up. If you’re using chrome, give Firefox a shot.


#3

Clear the cache on your browser. Works ever time for me


#4

yah changing browsers did it. It actually sat there just spinning trying to do and I had to go so just left and came back. refreshed and tried again and shows claim and working fine. Can access that server from other machines so all good

Thanks for help.

Can plex be updated now to latest version and continue working? What is command for it with QB?


#5

Yes, now that your server is claimed you will be able to update without issue. If you are on a normal (free) Plex account you can run upgradePlex to update to the latest Public version. Otherwise if you are on Plex Pass, you will need to do the following:

mkdir -p /root/plex-tmp
wget -O /root/plex-tmp/plex.deb "https://downloads.plex.tv/plex-media-server/1.1.0.2611-ba905d2/plexmediaserver_1.1.0.2611-ba905d2_amd64.deb"
newplex="$(dpkg -I /root/plex-tmp/plex.deb | grep Version | awk '{print $2}' | awk -F'[ -]' '{print $1}')"
cd plex-tmp
/usr/bin/dpkg -i /root/plex-tmp/plex.deb
mv /root/plex-tmp/plex.deb /root/plex-tmp/plex.$newplex.deb
cd
rm -rf plex-tmp
service plexmediaserver restart

#6

Thanks. I do have Pass so that helps.


#7

Wonderful. Here within the next 2 days we will have an updated version of the upgradePlex command that will cater to both Public and Pass users of Plex.