PlexRequests Reverse Proxy - Not Working

plexrequests

#1

I can’t get the PlexRequests Reverse Proxy working. I followed the instructions in Liara’s Post but it didn’t work at all. I get the following error:

So I checked /etc/apache2/sites-enabled to see if there is conf file for plexrequests and nothing. So I created one (plexrequests.conf:

<Location /plexrequests>
ProxyPass http://localhost:3000/plexrequests
ProxyPassReverse http://localhost:3000/plexrequests
AllowOverride All
Require all granted
</Location>

I’m thinking this might be where my problem is but I can’t be sure. Any help would be appreciated.

PS-I currently use http://localhost:3000 to access plexrequests. http://localhost:3000/plexrequests doesn’t actually work :confused:


#2

Hello @KaMoS69,

Did you try to access to PlexRequests with http://localhost/plexrequests ?


#3

Yes. I get the same error as above (404- NotFound).


#4

When I look the default PlexRequests.conf it seems there is no “AllowOverride All”.

Could you remove it, do sudo service apache2 restart and try to connect to http://localhost/plexrequests again please?


#5

That kinda worked. The problem was that I was using http instead of https. It’s working fine now. Thanks!