Plex Server not working


#1

I’m unable to get the plex server working.

plaza.quickbox.io/t/setting-up-an-ssh-tunnel-for-plex/135

That guide isn’t working on my end.

When I go to put http://localhost:8888/web into my web browser just says unable to connect.


#2

Have you connected to your server via PuTTY?


#3

I would not use the ssh tunnel and just use x2go. Connect into the server with x2go and use the browser in there to connect to the Plex and set it up.


#4

That’s great idea but now having trouble connecting with x2go. Never used it before.

Do I create a new key to pair with it? Or am I suppose to be using the same key already created for ssh. The passphrase doesn’t seem to work.


#5

as @Pinelli said you should use putty to open a tunnel for plex it is not to hard and the wiki is easy to follow just follow each step. once putty has ssh tunnel is setup then localhost:8888/web


#6

Ya I was trying that for hours with no luck.

When I go to put http://localhost:8888/web into my web browser just says unable to connect.


#7

You will need to ensure that you have the ssh session running in the background, typically to ensure there is a relay happening. Then once it’s confirmed you should be good to go.


#8

yeah the part where JM focuses on reclicking and be sure to have marked the tunnel you want to use before you clikc Open helped me as it wasn´t running in the background after first try!


#9

with zero luck for over 6 hours I’m trying to connect with X2Go. Disabled public key authorization because I couldn’t get that to work either.

Now I’m getting this error on X2Go

Connection failed sh: 1: x2golistsessions: not found

And this was after already giving up on the putty tunnel. That is not working either.


#10

It sounds like x2go isnt running. I use public key for my connections. I found that it specifically wants OpenSSH format for the private key.

Here are my x2Go settings:


#11

Can you think of anyway to check if x2go is actually running?

It says its installed on my dashboard.


#12

run this:
ps -ef | grep x2go


#13

I get one line

myusername 9470 9146 0 18:23 pts/1 00:00:00 grep --color=auto x2go


#14

It looks as if you have no session attached.

Here’s something to take note of, if you are on Ubuntu then there was an anomalous issue that was effecting ubuntu installs only in terms of X2Go. Please see this commit for the fix:

You can run the update directly from your dashboard and it should patch up your .bashrc file to make use of these changes. Then, uninstall/reinstall X2Go (server reboot not needed)

You should be able to login without issue using your master (sudo) account and password.

It’s possible this is effecting your X2Go.


#15

I’m on debian 6. Should I still try this fix? I’m assuming no.


#16

Debian 6 is not a supported OS


#17

Actually its debian 7 im sorry.


#18

7 & 6 are not too far off. Quite honestly, I have no idea how you installed QuickBox on Debian 6, did you modify this:

  if [[ ! "$DISTRO" =~ ("Ubuntu"|"Debian") ]]; then
    echo "$DISTRO: ${alert} It looks like you are running $DISTRO, which is not supported by QuickBox ${normal} "
    echo 'Exiting...'
    exit 1
  elif [[ ! "$CODENAME" =~ ("xenial"|"wily"|"trusty"|"jessie"|"wheezy") ]]; then
    echo "Oh drats! You do not appear to be running a supported $DISTRO release."
    echo "${bold}$SETNAME${normal}"
    echo 'Exiting...'
    exit 1
  fi

#19

Sorry I have been up too many hours. Its debian 7


#20

Ok, that explains it… I was curious and digging through how you managed to get that working.

Try to run the update from your dashboard and see if it addresses your issue, also do the uninstall/reinstall for good measure. It’s possible there may be a dependencies issue, I will need to run through that for good measure on a Debian 7 install.

Additionally, feel free to throw me you server details via PM and I will login and take a look.