Setting up an SSH Tunnel for Plex

mediaserver
tunnel
ssh
plex

#1

So, you have installed Plex and logged in via http://_yourserver_ip:32400/web/ and found that it is not reading your seedbox’s Plex Media Server. This can be frustrating but is an easy remedy with a little bit of work.

Installing Plex

The Problem

After installing, you login to your fresh new Plex only to find that your pre-existing Home Media Server is there, but your new Seedbox Plex Server is not listed (Drats!)…
This is where it is time to set a simple SSH Tunnel. What is an SSH Tunnel exactly?

Port forwarding via SSH (SSH tunneling) creates a secure connection between a local computer and a remote machine through which services can be relayed. Because the connection is encrypted, SSH tunneling is useful for transmitting information that uses an unencrypted protocol, such as IMAP, VNC, IRC and you guessed it… Plex.


The Solution

Setup time should only be around 10 minutes (tops)

This needs to be done from your local computer.

  1. Open PuTTY, enter your server IP address in the hostname and SSH port. Or, if you already have your server session setup and saved, just load the existing session.
  2. Go to “Connection > SSH > Tunnels”.
  3. Fill in “Source port” as "8888 and “Destination” as localhost:32400.
  4. Press the “Add” button.
  5. Now navigate back to the session homepage and press the “Save” button and then “Open” to connect to your server.
  • Open a web browser from your local computer and navigate to http://localhost:8888/web <-- type this is your browser exactly.

You will see a notice such as this appear when you first go to your plex localhost link:


  • Follow the on-screen instructions to complete the setup and add your media library.

Now you can access your media libraries from all of your devices at YOUR_SERVER_IP:32400.



###:warning: Whoa! Whoa! Whoa! MotherF&*$#!!!
In some cases, it is reported that some still have issues connecting… if this is you then do the following:

You will probably see a message informing you to claim the server after you login:

Let us now work on claiming it!

Enable Remote Access

You may see that Remote Access is disabled. If this is the case, Navigate to ‘Settings’ > ‘Server’ > ‘Remote Access’ and be sure to sign in if you haven’t already.

Now click the checkbox labeled “Manually specify public port”. Keep the port set to 32400 and press the ‘APPLY’ button.

If you have done everything correctly, your tunnel is now connected to your server from your local computer.

Check your Seedbox’s Plex Media Server for your new Connection

If all has been done properly, you should see the following:
Where Quickbox-Dev would be the name you gave your server



Allow insecure connections

:speaking_head: This step is not necessary in most cases and only needs to be set as a final attempt.

Towards the bottom of ‘Settings’ > ‘Web’ > ‘General’, you will see a dropdown labeled “Allow Fallback To Insecure Connections” Select ‘Always’ from the dropdown and press the ‘Save’ button



Still having problems connecting?

Don’t hesitate to open a support thread asking for help, a friendly member or myself may be available to walk you through the process.


Plex - Server not Found
Port for plex web url incorrect
Can't Claim Plex Server or access outside network
Newly installed Quickbox: Cannot enable Plex and BTSync
Plex cannot find my new QB server
Need help to make this work. plex multi user folders
Plex - "Service Unavailable" on New Install
Plex no Remote Access
Plex not seeing server...on the server? What?
Setting up an SSH Tunnel for Plex
Plex Server not working
Please help me out with Plex
Getting 404 when accessing Plex from Dashboard after update
How to route plex traffic an SSH tunnel when already tunneling?
Plex Media Server not found - Quickbox
Can't access plex server
#2

7 posts were merged into an existing topic: Setting up an SSH Tunnel for Plex


Trying to install Plexwatch and PlexwatchWeb
#3

PSA: Recent Plex updates cause reverse proxy breakage