Plex Requests 503 Service Unavailable


#1

Hey everybody,

I’ve been running into the following error when trying to open the Plex Requests web interface:

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.18 (Ubuntu) Server at Port 443

The error even persists after uninstalling then reinstalling Plex Requests.
I haven’t had this issue with any of the other application web interfaces, so I’m a bit lost as to what the problem is.

Any assistance would be greatly appreciated.
Thanks!


Plex Request NET don't work
#2

Hey there @N080D7,

what is the output of the following command :: systemctl status plexrequests?

Additionally, I think this is something that will need to be addressed in the next version patch list. What does your link to the Plex Requests application say on your dashboard? Is it http://SERVERIP:3000? If so, try to access Plexrequests via http://SERVERIP:3000/plexrequests


#3

This needs to be reworked due to the name change.

  • systemd service needs to be edited so its calling the right .exe
  • should probably change everything over to Ombi…/opt/ path, systemd service, panel, box, updater, etc, etc

I was able to install Ombi 2.0 by doing this but I’m sure it could be cleaner if I moved it all to Ombi but I didnt want to mess with the reverse proxy.

  • downloading Ombi 2.0
  • moving off /opt/plexrequests/
  • unzipping Ombi zip and renaming it to /opt/plexrequests
  • copying back in Plexrequests.sqlite to the /opt/plexrequests
  • renaming Plexrequests.sqlite to Ombi.sqlite
  • chowning the whole /opt/plexrequests to my user
  • editing the /etc/systemd/system/plexrequests.service to call Ombi.exe instead of Plexrequests.exe

#4

After running systemctl status plexrequests

● plexrequests.service
   Loaded: loaded (/etc/systemd/system/plexrequests.service; enabled; vendor pre
   Active: inactive (dead) since Mon 2017-01-16 23:26:13 CET; 8min ago
  Process: 16240 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
  Process: 16233 ExecStart=/usr/bin/screen -f -a -d -m -S plexrequests mono /opt

Jan 16 23:26:13 QuickBox systemd[1]: Starting plexrequests.service...
Jan 16 23:26:13 QuickBox systemd[1]: Started plexrequests.service.

On the dashboard it says http://SERVERDOMAIN/plexrequests, but it was unable to connect when I tried http://SERVERIP:3000 or http://SERVERIP:3000/plexrequests as well to connect directly.


#5

Will it restart if you issue from command line systemctl restart plexrequests


#6

I’ve got the exact same issue, for me running systemctl restart plexrequests, doesn’t have any effect.


#7

Noted

I’ll persue pushing in the suggestions by @RXWatcher later in the day. This issue is apparently going to increase in accordance with how they updated their application.

For bookmark purposes


#8

This will hopefully work…I havent tested the sed command. I use this for updating PlexRequests…so just modified it a bit to do the conversion. I find that I need to do as listed…completely remove old code, extract new and copy in old db.

#!/bin/bash
sudo curl -sL http://git.io/viA9C | grep -Po '(?<="browser_download_url": ")(.+\.zip)' | xargs sudo wget --quiet -O /opt/Ombi.zip
sudo systemctl stop plexrequests.service
sudo sed -i "s/PlexRequests.exe/Ombi.exe/g" /etc/systemd/system/plexrequests.service
sudo systemctl daemon-reload
sudo mv /opt/plexrequests /opt/plexrequests_old
sudo unzip -qq /opt/Ombi.zip -d /opt
sudo mv /opt/Release /opt/plexrequests
sudo cp /opt/plexrequests_old/PlexRequests.sqlite /opt/plexrequests/Ombi.sqlite
sudo chown -R jim:jim /opt/plexrequests
sudo systemctl start plexrequests.service
sudo rm -f /opt/Ombi.zip
sudo rm -rf /opt/plexrequests_old

#9

Confirm this works!


#10

Works here too! thanks!


#11

Worked initially, but first service unavailable notification came back, now it doesn’t respond at all anymore.


#12

@saltrocking, I’m not sure why this would work and then not work.

Are you using a /home mount partition for your install? If so, how much space do you have left on **/**root? df h


#13

I used your script to ombi, now it goes offline quiet quickly… Also i cant add couch or sonarr… Not sure if im really being stupid here but logs are showing that Ombi and couch cannot communicate.


#14

Hopefully we’ll get some answers from PlexRequests on this issue.


#15

I’m using a home folder. Executed the df -h command, nowhere something near full to see (but don’t see a reference to a root folder, when I typ the command). With a reboot, it comes up again, works for a while and then the 503 returns. reebok =saltrocking btw, lost my password but found it again.


#16

How long does it work for?

What I have found is that is that if you have a large amount of TV Shows in plex that Ombi will crash after while. This is the issue:

The Ombi system can’t handle the load…its actually Mono that can’t handle it and not Ombi. It’s a mono bug. Disable that checkbox and it stays up without issue.


#17

Think you’re right; I unintentionally put entered the wrong Plex Base Url last night. Although it logged an error every hour, it was still up and running in the morning. When I corrected it, a few hours later it was down again. I disabled to function to test further.

Size is definitely not the issue; it is not my production environment yet, it contains 5 episoded :slight_smile:


#18

Also with episode searching disabled, the service goes down after a while.


#19

I have same issue after doing what RSWatcher suggested by :

  • downloading Ombi 2.0
  • moving off /opt/plexrequests/
  • unzipping Ombi zip and renaming it to /opt/plexrequests
  • copying back in Plexrequests.sqlite to the /opt/plexrequests
  • renaming Plexrequests.sqlite to Ombi.sqlite
  • chowning the whole /opt/plexrequests to my user
  • editing the /etc/systemd/system/plexrequests.service to call Ombi.exe instead of Plexrequests.exe

My Ombi starts up just fine when running systemctl start plexrequests.service but after 5 mins max it stops the service again… and i can start it just fine again but same thing happens again… :slight_smile:


#20

Im getting the same. Even after removing and re-installing. never stays up long. plus will die while actually using it