Plex Not available outside your network


#1

Currently having issues getting plex to work outside the network, could the proxy change that happened in the last update have something to do with it?

Picture below, past experience with plex just required you to log in and it worked


#2

Update, so you if change it to Manually specify public port and change it to 31400 it changes to available from outside the network but I still can’t access it from the web client on plex.com

Some additional pictures


#3

I had this same issue, however, it was due to Double-NAT. You shouldn’t have to manually specify the port to get it to work. If you are behind a dual router setup I know that plex can present complications.


#4

Using a SyS Server with the distro kernal


#5

Do you have Plex installed on your home computer, or are you solely using plex.tv?


#6

Plex.tv is the main use right now

Just tried it on my android phone and it says “Direct Connection unavailable”

This is a fresh install also

There isn’t any chance the proxy would be the cause of this?


#7

I’d be curious to hear from any others that have had this issue. I experienced this same thing, left the ports alone, no manual specificity and it started working.

The Proxy shouldn’t be the cause as I have this on my system and have installed it for two others since the update and they are all working. I will however dig into this tomorrow and see what we can come up with.


#8

I had this problem as well but my solution was really simple. Clear your browser cache. This will force you to sign into Plex again. If you sign on from the screen where it shows your sever it will work.


#9

The proxy shouldn’t have anything to do with this and is actually password protected by htpasswd – therefore probably not accessible directly via plex.tv as there are no authentication options when adding a server.

That said, the proxy creates port 31400 in addition to leaving the original port 32400. When using 31400, it simply looks as if we are accessing the server from localhost rather than a remote host. 32400 will continue to block you unless you tunnel, because it knows you are not on localhost.

Clearing the browser cache and/or using another browser to test are also good ways to ensure nothing is up. Also, if you have a mobile phone you can try checking plex.tv from your mobile data. This will help you understand if your problems are localized to your home network or if it affects all remote hosts.


#10

Correct. We were able to handle this in PM by doing the following:

  1. Sign in to Plex web - server states ‘Server offline’ - remove the server.
  2. Sign out of Plex server
  3. Sign out of all Plex clients (web, android, etc.)
  4. Restart Plex server
  5. Sign back in into Plex server and do the same for all the clients

My apologies for not coming back and updating this thread. :blush:

####A Wiki Entry has been created on this topic.

Thank you everyone for your input on this. :thumbsup:


#11