Plex multi-users with Plex Pass - Problem folder not visible

users
plexmediaserver

#1

Hello,

I’ve just finished the install of QuickBox on my new Kimsufi. All works very well but I’ve a little issue with Plex and multi-users folders.

I want to create one library in plex for one users on QuickBox. I have a Plex Pass.

When I create the library “Movies #1” for /home/user1/torrents/rtorrent/movies, it works. I can see my movies in Plex.

But when I create a second library “#Movies #2” for /home/user2/torrents/rtorrent/movies, it not works. I can’t see in Plex the content of /home for another user.

I think it’s a problem with permissions. However, my users have both the group www-data.

If you have a solution, it could be nice !

This discussion is very close to mine : Need help to make this work. plex multi user folders

Many thanks.


#2

Hey there @antoineguilbert,

Try setting up the permissions for the users like the following:

username=ENTER USERNAME HERE
usermod -a -G ${username} plex
chown ${username}:plex /home/${username}
chmod 755 /home/${username}
setfacl -m g:${username}:rwx /home/${username}

#3

Many thanks for your fast answer ! It works ! :grinning:


#4

@JMSolo, I’m facing the same issue. I tried entering the command usermod -a -G ${tulsian} plex, however I get an error;`

Usage: usermod [options] LOGIN

Options:
-c, --comment COMMENT new value of the GECOS field
-d, --home HOME_DIR new home directory for the user account
-e, --expiredate EXPIRE_DATE set account expiration date to EXPIRE_DATE
-f, --inactive INACTIVE set password inactive after expiration
to INACTIVE
-g, --gid GROUP force use GROUP as new primary group
-G, --groups GROUPS new list of supplementary GROUPS
-a, --append append the user to the supplemental GROUPS
mentioned by the -G option without removing
him/her from other groups
-h, --help display this help message and exit
-l, --login NEW_LOGIN new value of the login name
-L, --lock lock the user account
-m, --move-home move contents of the home directory to the
new location (use only with -d)
-o, --non-unique allow using duplicate (non-unique) UID
-p, --password PASSWORD use encrypted password for the new password


#5

Don’t wrap your username with brackets.

BAD=${tulsian}
GOOD=tulsian

The code I provided above is copy/paste exactly as it is seen:

username=<ENTER USERNAME HERE>
usermod -a -G ${username} plex
chown ${username}:plex /home/${username}
chmod 755 /home/${username}
setfacl -m g:${username}:rwx /home/${username}