Plex is offline since installation

debian8

#1

Hello
Since the installation of Plex, it remains in offline status. The installationc went well, without error message. Can you help me ?



#2

Run these 5 lines in terminal

sudo systemctl stop plexmediaserver.service
sudo mkdir -p /var/lib/plexmediaserver
sudo adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex
sudo chown -R plex:plex /var/lib/plexmediaserver
sudo systemctl start plexmediaserver.service

credit to @RXWatcher


#3

Thanks @bate for your help.
I copied the 5 lines as indicated in the terminal but no change in the status of Plex


#4

I always have this issue on a fresh installation. Go to your Web Console, login and type sudo su

  1. Type box remove plex (you will probably get some errors, don’t worry)
  2. Type box install plex

Wait a few minutes and you should have Plex fully working. This has always worked for me.


#5

@wicked I followed your instructions.
I had 3 error messages for uninstalling Plex. It’s OK
For the installation, I am blocked on “Updating System” as in the screenshot below


#6

Now I have done an installation from the Dashboard. The Plex status is green but I still have a 503 error when opening IP :31400/web/


#7

I am also blocked on updating system, but it will install.

Could you try box uninstall plex and then box install plex

Because remove did not work. Then reboot your server


#8

I have this message
chown: invalid user: ‘plex:plex’


#9

Try and run these commands again:

sudo adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex
sudo chown -R plex:plex /var/lib/plexmediaserver

And then the box install plex

If your system is stuck on the “Updating System” just hit Enter once.


#10

@wicked @Titte95

I followed your instructions but still nothing :frowning:

When I do a sudo service plexmediaserver status I get:


#11

Which OS are you running?


#12

Debian 8 64bit


#13

port 31400 is just a forwarding port. Is this remaining non-accessible via your dashboard link as well?

Also, what is the status of Plex currently. Find out with systemctl status plexmediaserver


#14

I can actually launch Plex from the dashboard, but it launches I have “Service Unavailable”

Currently systemctl status plexmediaservergives me :

[[email protected]]:(0b)~$ sudo systemctl status plexmediaserver
● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
Active: failed (Result: start-limit) since Tue 2017-01-10 15:29:18 CET; 52min ago
Process: 28959 ExecStartPre=/bin/sh -c /usr/bin/test -d “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” || /bin/mkdir -p “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” (code=exited, status=217/USER)
Main PID: 23916 (code=exited, status=134)

Jan 10 15:29:13 107420hd42152 systemd[1]: Failed to start Plex Media Server …
Jan 10 15:29:13 107420hd42152 systemd[1]: Unit plexmediaserver.service enter…
Jan 10 15:29:18 107420hd42152 systemd[1]: plexmediaserver.service holdoff ti…
Jan 10 15:29:18 107420hd42152 systemd[1]: Stopping Plex Media Server for Lin…
Jan 10 15:29:18 107420hd42152 systemd[1]: Starting Plex Media Server for Lin…
Jan 10 15:29:18 107420hd42152 systemd[1]: plexmediaserver.service start requ…
Jan 10 15:29:18 107420hd42152 systemd[1]: Failed to start Plex Media Server …
Jan 10 15:29:18 107420hd42152 systemd[1]: Unit plexmediaserver.service enter…
Hint: Some lines were ellipsized, use -l to show in full.


#15

Have you tried to uninstall and reinstall (as root user)?

box remove plex then reinstall with the following box install plex

If you get to a point where it says “Installing Plex” and it just sits there… after a couple of minutes hit the Enter key on your keyboard and it should ignite the process to finish things up. I have only ever noticed this particular type of behavior with Debian.

Once installed if it’s still not active, do the steps that have been suggested by @RXWatcher

systemctl stop plexmediaserver.service
mkdir -p /var/lib/plexmediaserver
adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex
chown -R plex:plex /var/lib/plexmediaserver
systemctl start plexmediaserver.service

#16

I also have this issue. Here is what I’ve tried so far:

sudo nano /lib/systemd/system/plexmediaserver.service

Under [Service] add a new environmental variable:
Envrionment=LC_ALL=C

Save and exit, issue the command sudo systemctl daemon-reload

systemctl stop plexmediaserver.service mkdir -p /var/lib/plexmediaserver adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex chown -R plex:plex /var/lib/plexmediaserver systemctl start plexmediaserver.service

And I’m still getting:
● plexmediaserver.service - Plex Media Server for Linux Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled) Active: activating (auto-restart) (Result: exit-code) since Tue 2017-01-24 14:31:13 CST; 1s ago Process: 19822 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver /usr/lib/plexmediaserver/Plex\ Media\ Server (code=exited, status=134) Process: 19819 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS) Main PID: 19822 (code=exited, status=134)

Jan 24 14:31:13 plex.server.com systemd[1]: Unit plexmediaserver.service entered failed state.

I’ve also tried
box remove plex;box install plext;

Nothing has worked so far. I’ll update again once I get it going!


#17

Figured it out (at least on mine). I had a typo above. Environment not Envrionment!


#18

I think this is a valid solution until we pop out an update. More heads on this for testing the better :wink: