Not able to uninstall Subsonic

uninstall
subsonic

#1

I am trying to uninstall Subsonic - but it will not go away from my QB menu.

Not getting any error messages (how do I pull logs required to investigate this?).

Steps:

  1. Disabled Subsoninc via the Service Control Center
  2. Hit the button to uninstall via the Package Management Center

Now Subsonic is in a state where it’s still shown in the QB Menu, shown as installed under Package Management Center - and disabled under Service Control Center (not possible to re-enable it here). Accessing the WebUI results in a page not found.

The attempt to uninstall, was to wait using Subsonic till there is an option to install it as non-root (I’d like it in the /home/user/ directory). I read this as a hint it might come :slight_smile:


#2

It’s possible that the /install/.subsonic.lock file is not being removed, for that, I would have to check the uninstaller as it could be a simple edit that I overlooked on the files creation.

Subsonic will continue to be located at /srv/subsonic/, when mentioned about running as the user this was in regards to subsonic running as $username and not subsonic. When the Subsonic service runs as itself it is considered as running as root. This is by no means producing a vulnerable environment, just one of those instances where it feels it necessary to nag you about it.

With that said, check to see that the /srv/subsonic/ directory has been removed. Additionally, do a systemctl status subsonic and see if the service is dead. You may also ps aux|grep subsonic to check for thoroughness. This will help us ensure that it is both being killed as well as the leftover directories purged. If so, then we will simply need to adjust the removal of the leftover .subsonic.lock file.


#3

Just chiming in, I had the same problem and removing the .subsonic.lock file manually fixed it.


#4

Mine runs just fine from the default directory. Pointed it at my files in the /home/user/music directory, scanned the library and I am up and running. Is there some reason I should not do this? As far as running as root, I just logged in and made a non-root user.


#5

Indeed, the nag that is there initially is really just a disclaimer to do just this. It is always the best approach to creating a new user aside from the default if/when an application permits.


#6

I’m sorry about my super late response - just had a go at your suggestions.

I can confirm that rm /install/.subsonic.lock worked like a charm.

Thanks for the suggestions, and the clarification regarding to my root vs non-root question :slight_smile: