Need help with a server running Quickbox. Pls


#1

Hello,

First I would like to thanks the team for quickbox, I have been using it for few month and it’s wonderful.

I had no knowledge on Linux so this solution was perfect for me I started with a VM on one of my computer and 3 month ago I moved to https://www.hetzner.de/ for a i7 3790k 2x3to 16gb ram.

Everything was fine until last night, after I added some series and download quickbox started to act weird, slow and not charging some page. I decided to do a server reboot on the Server pannel since I could not access to the console on the web interface.

After the reboot I could not load the web interface or connect using ssh. I asked the support but since they said it’s not from hardware I should ask my administrator. Wich is me the total noob. They gave me a clue, about Rescue system and grub, so I started rescue using this page https://wiki.hetzner.de/index.php/Hetzner_Rescue-System/en
But now i don’t know what to do with rescue to try to fix the system without losing all data.

If someone could help me to solve this I would be very grateful.


#2

Not too sure why adding files for download would create access woes. You certainly shouldn’t be having any troubles accessing ssh by way of putty or terminal. Can you confirm if the server pings at all? Run ping SERVERIP from your own Windows command prompt and see if it returns anything. If it does, let me know and we can go from there.


#3

Thanks for help!

Well when i ping my server I got 4 packet lost, so it doesn’t work. i tried to reboot again. So i can’t connect to shh only when I use rescue.


#4

Yeah, it looks like your server is definitely offline and/or dead.

I have to run out for a meeting here in a few, but before then, I can try to do a quick analysis of your server in rescue mode to figure out what the problem may be. PM me your server details after you boot it into rescue mode and I will take a quick look.


#5

Thank you.

i just sent informations by PM.


#6

All sorted. The boot partition was full. Processes to fix the issue:

  1. @barbouz put the server into rescue mode
  2. I then mounted and chroot’ed into the filesystem. How?
mount /dev/md2 /mnt
mount /dev/md1 /mnt/boot
mount -t dev -o bind /dev /mnt/dev
mount -t proc -o bind /proc /mnt/proc
mount -t sys -o bind /sys /mnt/sys
chroot /mnt
  1. I then checked the status of space on the partitions with df -h
  2. Yup, /boot was 100% full, so I ran apt -y autoremove && apt -y autoclean. This freed up some space putting the partition back down to 18%
  3. Noticed a lot of apt updates available for the OS. Yup, time to update. Ran apt -y update && apt -y upgrade to complete the service. Of course I followed this up with another remove/clean, just in case.
  4. Rebooted the server with reboot and waited for it to come back online.
  5. @barbouz confirmed it was all back online
  6. We sang songs of friendship and happiness and reminisced of Ye’ Old days… huzzah!
  7. Just lied. None of that #8 happened, but we were both happy :slight_smile:

Impossible to boot and update the server, rescue mode
#7

i would like to thank @JMSolo for his help and his patience.

He did all the job alone sine I was helpless and he saved my server!

Thanks again, we are lucky to have you there!


#8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.