Impossible to boot and update the server, rescue mode


#1

Dears,

I have followed the following solution in rescue mode: Need help with a server running Quickbox. Pls
I have the same issue with the same provider (not linked), my root is full 100%.

Filesystem Type Size Used Avail Use% Mounted on
/dev/md2 ext4 5.4T 4.1T 1.2T 79% /
/dev/md1 ext3 488M 484M 0 100% /boot
udev devtmpfs 7.7G 0 7.7G 0% /dev

But when I run the autoremove autoclean commands I have the following issue:

“You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies:
linux-image-extra-4.10.0-37-generic : Depends: linux-image-4.10.0-37-generic but it is not installed
linux-image-generic-hwe-16.04 : Depends: linux-image-4.10.0-37-generic but it is not installed
E: Unmet dependencies. Try using -f.”

I run then apt-get -f install command but I have the following error because the space is full:
“No space left on device”

“Unpacking linux-image-4.10.0-37-generic (4.10.0-37.41~16.04.1) …
dpkg: error processing archive /var/cache/apt/archives/linux-image-4.10.0-37-generic_4.10.0-37.41~16.04.1_amd64.deb (–unpack):
cannot copy extracted data for ‘./boot/vmlinuz-4.10.0-37-generic’ to ‘/boot/vmlinuz-4.10.0-37-generic.dpkg-new’: failed to write (No space left on device)
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.10.0-37-generic /boot/vmlinuz-4.10.0-37-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.10.0-37-generic /boot/vmlinuz-4.10.0-37-generic
Errors were encountered while processing:
/var/cache/apt/archives/linux-image-4.10.0-37-generic_4.10.0-37.41~16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)”

Vicious circle :frowning:my bad… why I didn’t clean the updates/upgrades…
Someone has any clue about how to fix it easily? @JMSolo if you are still on that forum it will be much appreciated. :slight_smile:

Thx a lot for your help,
Corend


#2

sudo su
switch to root

uname -r
this shows what version you are on now

ls /boot
shows the extra stuff taking up all the room which is causing that disk full error.

you can try ‘apt autoremove’ to see if it frees up some space, but it might not. i usually just manually delete the files im not using in /boot/ and carry on with updates. probably a better way to do it but i dont know it and this way works.


#3

Thx for your help.

I try this ls /boot command and I have this:

rescue:/# ls /boot
abi-4.10.0-28-generic initrd.img-4.4.0-89-generic
abi-4.10.0-30-generic initrd.img-4.4.0-91-generic
abi-4.10.0-32-generic initrd.img-4.4.0-92-generic
abi-4.10.0-33-generic initrd.img-4.4.0-93-generic
abi-4.10.0-35-generic initrd.img-4.8.0-52-generic
abi-4.4.0-89-generic lost+found
abi-4.4.0-91-generic System.map-4.10.0-28-generic
abi-4.4.0-92-generic System.map-4.10.0-30-generic
abi-4.4.0-93-generic System.map-4.10.0-32-generic
abi-4.4.0-96-generic System.map-4.10.0-33-generic
abi-4.4.0-97-generic System.map-4.10.0-35-generic
abi-4.8.0-52-generic System.map-4.4.0-89-generic
config-4.10.0-28-generic System.map-4.4.0-91-generic
config-4.10.0-30-generic System.map-4.4.0-92-generic
config-4.10.0-32-generic System.map-4.4.0-93-generic
config-4.10.0-33-generic System.map-4.4.0-96-generic
config-4.10.0-35-generic System.map-4.4.0-97-generic
config-4.4.0-89-generic System.map-4.8.0-52-generic
config-4.4.0-91-generic vmlinuz-4.10.0-28-generic
config-4.4.0-92-generic vmlinuz-4.10.0-30-generic
config-4.4.0-93-generic vmlinuz-4.10.0-32-generic
config-4.4.0-96-generic vmlinuz-4.10.0-33-generic
config-4.4.0-97-generic vmlinuz-4.10.0-35-generic
config-4.8.0-52-generic vmlinuz-4.4.0-89-generic
grub vmlinuz-4.4.0-91-generic
initrd.img-4.10.0-28-generic vmlinuz-4.4.0-92-generic
initrd.img-4.10.0-30-generic vmlinuz-4.4.0-93-generic
initrd.img-4.10.0-32-generic vmlinuz-4.4.0-96-generic
initrd.img-4.10.0-33-generic vmlinuz-4.4.0-97-generic
initrd.img-4.4.0-87-generic vmlinuz-4.8.0-52-generic

Do I have to clean all of those? If yes then how?


#4

what i do, after you see what number you are on after running uname -r, is cd /boot

rm *-xx* replacing xx with those low number versions you arent using.

i am no linux expert by any means, but as far as i know your system is only running one version at a time and seems to forget to remove those old ones. perhaps you can remove a few of those low 20s and 30s, then run apt autoremove to remove some.

this doesnt happen on my server, but on my friends hetzner box i have to go in every few months and clean that folder out.


#5

I finally did all the needed clean up. Ouf… :slight_smile:
But now rtorrent is not working. I reinstall it and did a systemctl restart [email protected] but it launch during 1 mn and stop. I will create another topic then.