Mount /home/quickbox/torrents/rtorrent to remote filesystem using sshfs



Good afternoon! First and foremost, I LOVE Quickbox! it’s so cool!

Here is a little info about my setup.

OVH vps, 1 core, 2gb ram, 10gb hd, 100mbit network
running ubuntu 16.04.

I hardened it a little (ssh keys, removed ability to password login, etc) and then installed QuickBox.
Quickbox is working well as is right now (without mounting remote storage).

I would like to mount the /home/quickbox/torrents/rtorrent folder to a folder on my home server using sshfs. That way the watch directory, download directory and finished directory would all be on my home network (only 10gb of space on the VPS!).

I installed sshfs, and can mount the remote storage (using the allow_other option, so that the quickbox user can access it). I am able to browse the remote storage under the mount point as both root and quickbox, but when I go into rutorrent and try to set up autotools and the default download location, nothing shows up when I click the icon to select the location (see example image).

I have also tried mounting my remote file storage at /mnt/VIDEO and then created symbolic links from the watch, inprocess and finished folders on the remote storage to /home/quickbox/torrents/rtorrent/watch, /home/quickbox/torrents/rtorrent/inprocess, and /home/quickbox/torrents/rtorrent/finished folders respectively. when I do this, the rtorrent interface shows me the “.” and “…” options in the rtorrent folder, but nothing else (not the links even!). See below for an example picture of that scenario.

in another topic (CurlFTPFS & Quickbox) @valkyre14 had mentioned they had sshfs working flawlessly, but it was very slow. I’m ok with slow, as long as I can get it working!

Any help you can provide would be much appreciated!


example of mounting remote storage to /home/quickbox/torrents/rtorrent

example of mounting remote storage to /mnt/VIDEO and using symbolic links under /home/quickbox/torrents/rtorrent

and symbolic links


I did a little more testing. I have come to find that while I can browse the sshfs mount, I can’t edit anything there. I can however

  • cp and/or mv from the local file system out to the mount.
  • ‘touch’ a file out on the sshfs mount, however it gives me an error (touch: setting times of ‘test.txt’: Operation not permitted). It should be noted the file DOES get created.
  • delete files from the mount (both files/folders I have created using touch/mkdir, as well as ones that were already out there and created on the windows side of things).

This is looking more and more like an sshfs / windows 2012r2 running openssh issue as opposed to a quickbox issue. Still, any help anyone can provide would be much appreciated!