Install Flood on your seedbox

flood
rtorrent

#21

I’m still trying to learn my way around Apache. Would anyone be able to shed some light on how I could set up a reverse proxy to serve this at something like http://mydomain.com/flood


#22

I’ve updated the wiki post to include SSL configuration and a possible solution for people getting connection refused when accessing Flood.


#23

I would use 127.0.0.1 as that is local 0.0.0.0 is meant for other kind of things


#24

I wasn’t able to access Flood when using 127.0.0.1, if you have a workaround I’ll add it to the wiki. :slight_smile:


#25

no i dont just think from a ip routing standpoint but not sure why would not work as i have not tried to set up in a while


#26

Hello,

Great tutorial, many thanks :slight_smile:

I’m running QuickBox v2.5.2 and when I run the RUN UPDATE command it overrides the custom.menu.php settings and everything reverts back to default. As a result I need to re-add the required information for Flood to show up in the dashboard. Not sure if anyone experienced this?

Thank you


#27

The recent update for QuickBox I left in a \cp -fR command that overwrote the directories (this was for testing and I failed to remove it from the update :blush: ). It’s now using the rsync method of updating which excludes the custom files. If it’s still overwriting your files, let me know and I will press this higher in priority.


#28

Hello,

Very much appreciated, thank you it’s all good now :))))


#29

Hello I tried a lot to get this working,

Changed the config file, different ports, reset the server etc…

I keep getting ERR_CONNECTION_REFUSED

Is there a log file somewhere to conduct where something goes wrong?


#30

So, I got a VPS to play around with Quickbox, wanted to install flood and stuff.
I build the VPS with Ubuntu 16.04, made all necessary updates, installed QuickBox and precisely followed the instructions in this tutorial. But when I wanted to access IP:3030, I would get “ERR_CONNECTION_REFUSED” in Chrome. Also changing the host to 127.0.0.1 didn’t work. Really don’t know what’s wrong. Wanna look into it?


#31

Are you trying to access Flood with https://ip:3030? If not Flood will return a connection error if accessing via http:// with SSL enabled. If you’ve tried that and it still doesn’t work, you may want to ask over at Flood’s Slack channel. I haven’t had any connection errors since I changed floodServerHost to 0.0.0.0.


#32

I’m trying to access Flood via IP:3030. I set ssl=false, since I don’t use Let’s Encrypt yet. I only changed the floodServerPort to 3030 and the floodServerHost to ‘0.0.0.0’ and the name in the flood.service script.
But I still get ERR_CONNECTION_REFUSED.

Here are my settings:


#33

check the status for the flood.service

systemctl status flood

i suggest the service runs, but with something equal to this:

Active: active (running) since Mon 2018-01-08 22:26:16 UTC; 1s ago

all the time you check the status you would see a time <=1s…

there is a missing point in the first post, after

npm install --production

add

npm run build

and restart your service…

if this would not help, remove the

Restart=always
from the service file for testing purpose

reload it:

systemctl daemon-reload

restart the service

systemctl restart flood

and check the systemlog

journalctl -xe

if you would like to use the ssl thing, it seems that flood only starts with the “user” and so it have to have right to access it (the status of the service would show an error with the file)


#34

I’ve made some changes to the prerequisites and systemd script which should solve the connection issues people have been having. If it’s still not working for some, post your systemctl status flood logs as @benba suggested.


#35

Thanks @Vustom for your work on this. I’m going to have this officially included in the package list by this weekends end, along with a version bump.


#36

Replace DOMAIN with the domain entered in the Let’s Encrypt setup then save the file with Ctrl + X then Y. If you haven’t installed Let’s Encrypt yet, su into root, run box install letsencrypt and follow the prompts.

@Vustom is that really necessary to use letsencript to make flood to work??
I was on the halfway of seting up flood until I noticed this requirement… TBH I don’t want to purchase a domain just for this GUI interface

Regards


#37

Nope, just leave the SSL option in config.js as false.

I would also suggest changing the secret in config.js to something else, I’ll include this in the original post shortly.