Install Flood on your seedbox

flood
rtorrent

#21

I’m still trying to learn my way around Apache. Would anyone be able to shed some light on how I could set up a reverse proxy to serve this at something like http://mydomain.com/flood


#22

I’ve updated the wiki post to include SSL configuration and a possible solution for people getting connection refused when accessing Flood.


#23

I would use 127.0.0.1 as that is local 0.0.0.0 is meant for other kind of things


#24

I wasn’t able to access Flood when using 127.0.0.1, if you have a workaround I’ll add it to the wiki. :slight_smile:


#25

no i dont just think from a ip routing standpoint but not sure why would not work as i have not tried to set up in a while


#26

Hello,

Great tutorial, many thanks :slight_smile:

I’m running QuickBox v2.5.2 and when I run the RUN UPDATE command it overrides the custom.menu.php settings and everything reverts back to default. As a result I need to re-add the required information for Flood to show up in the dashboard. Not sure if anyone experienced this?

Thank you


#27

The recent update for QuickBox I left in a \cp -fR command that overwrote the directories (this was for testing and I failed to remove it from the update :blush: ). It’s now using the rsync method of updating which excludes the custom files. If it’s still overwriting your files, let me know and I will press this higher in priority.


#28

Hello,

Very much appreciated, thank you it’s all good now :))))


#29

Hello I tried a lot to get this working,

Changed the config file, different ports, reset the server etc…

I keep getting ERR_CONNECTION_REFUSED

Is there a log file somewhere to conduct where something goes wrong?


#30

So, I got a VPS to play around with Quickbox, wanted to install flood and stuff.
I build the VPS with Ubuntu 16.04, made all necessary updates, installed QuickBox and precisely followed the instructions in this tutorial. But when I wanted to access IP:3030, I would get “ERR_CONNECTION_REFUSED” in Chrome. Also changing the host to 127.0.0.1 didn’t work. Really don’t know what’s wrong. Wanna look into it?


#31

Are you trying to access Flood with https://ip:3030? If not Flood will return a connection error if accessing via http:// with SSL enabled. If you’ve tried that and it still doesn’t work, you may want to ask over at Flood’s Slack channel. I haven’t had any connection errors since I changed floodServerHost to 0.0.0.0.


#32

I’m trying to access Flood via IP:3030. I set ssl=false, since I don’t use Let’s Encrypt yet. I only changed the floodServerPort to 3030 and the floodServerHost to ‘0.0.0.0’ and the name in the flood.service script.
But I still get ERR_CONNECTION_REFUSED.

Here are my settings:


#33

check the status for the flood.service

systemctl status flood

i suggest the service runs, but with something equal to this:

Active: active (running) since Mon 2018-01-08 22:26:16 UTC; 1s ago

all the time you check the status you would see a time <=1s…

there is a missing point in the first post, after

npm install --production

add

npm run build

and restart your service…

if this would not help, remove the

Restart=always
from the service file for testing purpose

reload it:

systemctl daemon-reload

restart the service

systemctl restart flood

and check the systemlog

journalctl -xe

if you would like to use the ssl thing, it seems that flood only starts with the “user” and so it have to have right to access it (the status of the service would show an error with the file)


#34

I’ve made some changes to the prerequisites and systemd script which should solve the connection issues people have been having. If it’s still not working for some, post your systemctl status flood logs as @benba suggested.


#35

Thanks @Vustom for your work on this. I’m going to have this officially included in the package list by this weekends end, along with a version bump.


#36

Replace DOMAIN with the domain entered in the Let’s Encrypt setup then save the file with Ctrl + X then Y. If you haven’t installed Let’s Encrypt yet, su into root, run box install letsencrypt and follow the prompts.

@Vustom is that really necessary to use letsencript to make flood to work??
I was on the halfway of seting up flood until I noticed this requirement… TBH I don’t want to purchase a domain just for this GUI interface

Regards


#37

Nope, just leave the SSL option in config.js as false.

I would also suggest changing the secret in config.js to something else, I’ll include this in the original post shortly.


#38

It depends on your apache setup (I changed mine to organize my apache conf files a little better). But in the main conf file for your qb/rtorrent file, I added this:

    ProxyPass /flood http://localhost:3030
    ProxyPassReverse /flood http://localhost:3030
    ProxyPass /overview http://localhost:3030
    ProxyPassReverse /overview http://localhost:3030

I had to setup to proxypass declarations for /flood and /overview (if you refreshed after logged in, it would give me an error for /overview

In the flood config.js, change the baseUri to “/flood”

Also, in the Proxy declaration, where you have the rutorrent password setup, I had to modify it slightly to do this:
<Proxy *>
SetEnvIf Request_URI ^/flood/? DONT_NEED_AUTH=true
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd’
AddDefaultCharset Off
Order deny,allow
Satisfy any
Deny from all
Allow from env=DONT_NEED_AUTH
Require valid-user

This was so that I didn’t have to “login” twice, once with the digest login, and then again into flood itself


#39

Is this included in the package list now? Can’t seem to find it.

:slight_smile:

I attemted the install again but getting this error :slight_smile:

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.12.14-041214-generic with 1.
dpkg: error processing package initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 linux-image-extra-4.4.0-122-generic
 linux-image-generic
 linux-generic
 linux-image-extra-4.4.0-121-generic
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
tv:~# 

If I look at my space it is :

tv:~# df -k
Filesystem Type 1K-blocks Used Available Use% Mounted on
udev devtmpfs 1958984 0 1958984 0% /dev
tmpfs tmpfs 396380 20608 375772 6% /run
/dev/sda3 ext4 1920420800 1453288580 369557412 80% /
tmpfs tmpfs 1981892 24 1981868 1% /dev/shm
tmpfs tmpfs 5120 0 5120 0% /run/lock
tmpfs tmpfs 1981892 0 1981892 0% /sys/fs/cgroup
/dev/sda1 ext4 193242 156005 22974 88% /boot
cgmfs tmpfs 100 0 100 0% /run/cgmanager/fs
tmpfs tmpfs 396380 0 396380 0% /run/user/1001
tmpfs tmpfs 396380 0 396380 0% /run/user/1000
tv:~#

I think my /boot folder is the problem but can’t seem to find a way to increase the size off it. :expressionless:
Anyone know more on this ?


#40

Scratch my post above, I’ve managed to fix the space problem by removing old kernal versions. Now the /boot folder has more space and the install could continue.

It ran successfully, but I couldn’t get flood started.

The service output is ;

    tv:/srv/flood# systemctl status flood
● flood.service
   Loaded: loaded (/etc/systemd/system/flood.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Mon 2018-04-30 20:36:38 CEST; 7min ago
  Process: 19380 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 19380 (code=exited, status=1/FAILURE)

Apr 30 20:36:37 tv.####.online systemd[1]: flood.service: Main process exited, code=exited, status=1/FAILURE
Apr 30 20:36:37 tv.####.online systemd[1]: flood.service: Unit entered failed state.
Apr 30 20:36:37 tv.####.online systemd[1]: flood.service: Failed with result 'exit-code'.
Apr 30 20:36:38 tv.####.online systemd[1]: flood.service: Service hold-off time over, scheduling restart.
Apr 30 20:36:38 tv.####.online systemd[1]: Stopped flood.service.
Apr 30 20:36:38 tv.####.online systemd[1]: flood.service: Start request repeated too quickly.
Apr 30 20:36:38 tv.####.online systemd[1]: Failed to start flood.service.
tv:/srv/flood#

Also the journalctl -xe output

tv:/srv/flood# journalctl -xe
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The process /usr/bin/npm could not be executed and failed.
-- 
-- The error number returned by this process is 3.
Apr 30 20:55:23 tv.####.online systemd[1]: flood.service: Main process exited, code=exited, status=217/USER
Apr 30 20:55:23 tv.####.online systemd[1]: flood.service: Unit entered failed state.
Apr 30 20:55:23 tv.####.online systemd[1]: flood.service: Failed with result 'exit-code'.
Apr 30 20:55:25 tv.####.online systemd[1]: Stopped Flood rTorrent Web UI.
-- Subject: Unit flood.service has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit flood.service has finished shutting down.
Apr 30 20:55:25 tv.####.online systemd[1]: Started Flood rTorrent Web UI.
-- Subject: Unit flood.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit flood.service has finished starting up.
-- 
-- The start-up result is done.
Apr 30 20:55:25 tv.####.online systemd[25535]: flood.service: Failed at step USER spawning /usr/bin/npm: No such process
-- Subject: Process /usr/bin/npm could not be executed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The process /usr/bin/npm could not be executed and failed.
-- 
-- The error number returned by this process is 3.
Apr 30 20:55:25 tv.####.online systemd[1]: flood.service: Main process exited, code=exited, status=217/USER
Apr 30 20:55:25 tv.####.online systemd[1]: flood.service: Unit entered failed state.
Apr 30 20:55:25 tv.####.online systemd[1]: flood.service: Failed with result 'exit-code'.
lines 1432-1465/1465 (END)