Help me determine weak link (plex buffering)


#1

Need to identify the weak link in my plex buffering… it happens every now and again and its troubling because i have this robust server in OVH Canada. I mean 8 thread, 32 GB ram, Gigabit connection, etc. And indeed when i look at dashboard during any streams (transcoding or not), the resources are barely taking a dent… sometimes cpu may go up to 50% during transcodes but it’ll drop down shortly afterwards… could it be my connection to OVH? Peering? how can i test that? my internet speeds are over over 130 mbps in general. I thought perhaps ACD, but i was able to rule it out when the same problem happened with streaming content saved locally.

thanks.


#2

You could always try downloading test files from your server when the buffering occurs.

Anything in the Downloads section of your QuickBox Dashboard would help you determine if it’s the link speed between you and the server or something else :slight_smile:


#3

good point! totally forgot about that… how silly of me… will try that next time… thanks for you answer!!


#4

MTR and iperf will help.

I will run a mtr from my server to my home and I run an iperf server on my seedbox to test the path going both ways.


#5

how can i set that up… is there a tutorial i can follow?

thanks!


#6

mtr should already be on the server…just type:mtr <your home IP address>

iperf:

sudo apt install iperf
sudo apt install iperf3

followed byiperf -s or iperf3 -s

You’ll then need an iperf or iperf3 client on your home side. iperf -c server will connect to your server and check transfers from home to server. iperf -c server -R will check seedbox to home.

I run mine as a service on my seedbox so the iperf servers are always running.

i


#7

cool i’ll try that! thanks again!


#8

i ran the test: i get the following… how are these speeds?


#9

that works out about 1.5MB/s

that would be able to do one stream of 720 without too much hassle. Not sure about the higher res 1080s though.


#10

so i’m rather confused… when downloading a file from my box, it hit and stayed steady at 13-15 MB/s, which is rather good. yet i’m still experiencing buffering while streaming a file… here is what the dashboard reports … it buffered several times during this period… any thoughts?? what can it be?

Screen Shot 2017-02-16 at 10.52.27 PM


#11

What’s your IO performance with bench.sh? Is this one of those online servers with the dicky hard drives ?


#12

its OVH. they have a good reputation… here are my results…


#13

so it’s not disk.
network seems stable at 13mbit
and cpu isn’t being taxed…

I’m stumped :confused:


#14

What does the MTR show?


#15

hey! just ran this from my windows htpc from home… anything strange?

WinMTR Statistics

WinMTR statistics

Host % Sent Recv Best Avrg Wrst Last
router.asus.com 0 126 126 0 0 2 1
96.120.89.21 0 126 126 8 10 27 8
te-0-7-0-15-sur03.pleasanton.ca.sfba.comcast.net 0 126 126 8 12 23 13
be-226-rar01.pinole.ca.sfba.comcast.net 0 126 126 9 13 24 9
hu-0-1-0-1-ar01.santaclara.ca.sfba.comcast.net 0 126 126 11 13 29 11
be-33651-cr01.sunnyvale.ca.ibone.comcast.net 12 87 77 0 14 90 12
be-10919-cr01.1601milehigh.co.ibone.comcast.net 1 122 121 37 40 128 44
be-11719-cr02.denver.co.ibone.comcast.net 1 122 121 38 42 59 42
be-10517-cr02.350ecermak.il.ibone.comcast.net 0 126 126 60 65 76 61
be-10563-pe01.350ecermak.il.ibone.comcast.net 0 126 126 60 64 74 64
be100-153.chi-5-a9.il.us 0 126 126 57 64 74 65
be10-1313.bhs-g2-a9.qc.ca 1 122 121 0 80 116 76
vl20.bhs-g2-a75-lo2.qc.ca 1 122 121 0 79 95 79
be50-7.bhs-3b-a9.qc.ca 1 122 121 0 80 95 77
ns517431.ip-158-69-27.net 1 122 121 0 79 93 81

#16

It looks good. I would run it the other way…from the server to your home.


#17

ah ok…


#18

its making it past the first one so its probably just that switch isn’t responding to pings. If it was really 100% loss then it wouldnt be moving past that. Your 18.8% loss is more concerning…close to 20% of the packets are being lost at that switch.

Read through that to help understand what MTR is saying.


#19

is this somthing that will correct itself or should i look for a new server w/ a better MTR verdict?


#20

I think Comcast has a lot of network issues. I can run a MTR from my online.net box for you tomorrow…Maybe it’s better otherwise probably live with it. A different player might help…I noticed that I buffer more on a browser than a Roku.