Fresh install on Debian - No Disk Status and Can No longer use SSH


#1

Hi all,

I’ve got a dedi plan with So You Start and I did a fresh install of QuickBox just now on Debian 8 (my linux skills are pretty novice btw so bear with me!)

Firstly, I can access the dashboard perfectly. However, I’ve got the following issues:

  • “Your Disk Status” is completely blank. I.e. nothing is shown in the box at all.
  • “Rtorrent” service status is shown as disabled. I can’t work out how to enable it. But the rutorrent web interface works.
  • I can no longer SSH onto my server. The biggest issue. It worked fine before installing QuickBox but now I get a “Connection refused” error.

Thanks!

J


#2

It changes your port to 4747 for SSH. This is documented within the readme.

It sounds like you are possibly either using a /home mount and installed it for a /(root) mounted partition, or… you are using a RAID1 setup and at the moment RAID1 is not supported by QuickBox.

Let’s see what we can figure out.

What does the following command show?
Type into SSH lsblk. It should show output similar to that of below: (Results will vary)

[[email protected]]:(449.9kb)~# lsblk
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda      8:0    0   10G  0 disk
├─sda1   8:1    0    9G  0 part /
├─sda2   8:2    0    1K  0 part
└─sda5   8:5    0 1022M  0 part [SWAP]
sr0     11:0    1 1024M  0 rom
[[email protected]]:(449.9kb)~#

Next, show me the contents of your /etc/fstab. Type cat /etc/fstab into your console.

Once I have those results we’ll have something to go off of and can make it work from there :slight_smile:


#3

Re: SSH - D’oh! Must have completely missed that point. Can connect fine now! Apologies.

Running that command it looks like I have a RAID1 setup (not too familiar with what RAID is, but I get the gist)

The command run shows the following:

[[email protected]]:(631.2kb)~# lsblk
NAME    MAJ:MIN RM    SIZE RO TYPE  MOUNTPOINT
sda       8:0    0    1.8T  0 disk  
├─sda1    8:1    0 1004.5K  0 part  
├─sda2    8:2    0   19.5G  0 part  
│ └─md2   9:2    0   19.5G  0 raid1 /
├─sda3    8:3    0    1.8T  0 part  
│ └─md3   9:3    0    1.8T  0 raid1 /home
└─sda4    8:4    0    511M  0 part  [SWAP]
sdb       8:16   0    1.8T  0 disk  
├─sdb1    8:17   0 1004.5K  0 part  
├─sdb2    8:18   0   19.5G  0 part  
│ └─md2   9:2    0   19.5G  0 raid1 /
├─sdb3    8:19   0    1.8T  0 part  
│ └─md3   9:3    0    1.8T  0 raid1 /home
└─sdb4    8:20   0    511M  0 part  [SWAP]

As for the contents of /etc/fstab:

[[email protected]]:(631.2kb)~# cat /etc/fstab
# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/md2	/	ext4	usrquota,errors=remount-ro,relatime	0	1
/dev/md3	/home	ext4	defaults,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
/dev/sdb4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
tmpfs		/dev/shm	tmpfs	defaults	0	0
devpts		/dev/pts	devpts	defaults	0	0

Thanks for your help :slight_smile:


#4

You know what? Let’s try something here!

Change this:

# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/md2	/	ext4	usrquota,errors=remount-ro,relatime	0	1
/dev/md3	/home	ext4	defaults,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
/dev/sdb4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
tmpfs		/dev/shm	tmpfs	defaults	0	0
devpts		/dev/pts	devpts	defaults	0	0

to this:

# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/md2	/	ext4	defaults,relatime	0	1
/dev/md3	/home	ext4	usrquota,errors=remount-ro,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
/dev/sdb4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
tmpfs		/dev/shm	tmpfs	defaults	0	0
devpts		/dev/pts	devpts	defaults	0	0

I am curious if we can manage to get Raid1 installs working. If you don’t mind giving it the ol’ college try.


#5

Got it - so I edited the file in nano and changed those two lines over and rebooted the server. Looks like the issue is still there though - Rtorrent and Irssi are disabled and nothing on the disk display

Happy to try anything else!


#6

Yeah, it’s not reading it from the correct disk. Raid1 is funky. You should be able to reinstall your server from the SYS control panel. Just use the setting ‘install everything on one disk’ (something to that effect) and then put just a little bit of space on the /(root) mount and the rest on /home

Then everything should go splendidly. I am going to be looking into more intelligent ways for the script to play with multiple disks setups - be it various RAID or no RAID. It’s in the development pipeline for next week. Once the update platform is stable.


#7

Thanks for your help!

I reinstalled and still get the Rtorrent “disabled” icon (but under “service controller” rtorrent is set to “on” - same with irssi) - is this just a bug or

Also, now in the disk space box I now get:

Free: -3.8147e-06 GB
Used: 3.8147e-06 GB
Size: 0 GB
Disk Space
INF% Used
You have used INF% of your total disk space

Any ideas? This is coming off of a fresh install of QuickBox. Is this because I selected “root” instead of “home” in the install?

Thank you! :slight_smile:


#8

If you are installing on a /home mounted install… why would you select /(root)?

Show me your /etc/fstab once more please.

We can fix it, but I need to be certain this is self sabotage and not the script :stuck_out_tongue_winking_eye:


#9

I think it’s the fact that I’m quite frankly rubbish at linux :stuck_out_tongue: I didn’t quite understand the difference between installing on /home or /(root). Self sabotage is the most likely option!

Here’s /etc/fstab:

[[email protected]]:(924.3kb)~# cat /etc/fstab
# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/sda2	/	ext4	usrquota,usrquota,errors=remount-ro,relatime	01
/dev/sda3	/home	ext4	defaults,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
devtmpfs	/dev	devtmpfs	rw	0	0
[[email protected]]:(924.3kb)~#

#10

No worries. I have had a few people tell me my way of phrasing questions is rather poor and confusing… this is something I need to work on. I literally paint with crayons in that department.

Ok, so… change this:

# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/sda2	/	ext4	usrquota,errors=remount-ro,relatime	01
/dev/sda3	/home	ext4	defaults,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
devtmpfs	/dev	devtmpfs	rw	0	0

to this:

# <file system>	<mount point>	<type>	<options>	<dump>	<pass>
/dev/sda2	/	ext4	defaults,relatime	01
/dev/sda3	/home	ext4	usrquota,errors=remount-ro,relatime	1	2
/dev/sda4	swap	swap	defaults	0	0
proc		/proc	proc	defaults		0	0
sysfs		/sys	sysfs	defaults		0	0
devtmpfs	/dev	devtmpfs	rw	0	0

Then do the following as we now need to rebuild quotas for use on the proper mount point:

quotaoff -a
service quota stop
mount -o remount /home
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

You will now need to navigate to your dashboard directory to pull the files the script removed thinking this was a /(root) mount install. So do this:

cd /srv/rutorrent/home
git config --global user.email "[email protected]"
git config --global user.name "quickbox"
git reset --hard origin/master
git pull
cd widgets
rm disk_data.php && mv disk_datah.php disk_data.php

Let's see if that solves it... then run the **``setdisk``** command to set your user quota.

#11

Your questions were perfectly clear - I’m just simply a novice linux user but I’m getting there - and diagnostics like this only help me understand what I’m doing more!

I performed the commands as you specified and pleased to say the disk monitor now correctly reads :slight_smile: ! The status of Rtorrent is still showing as disabled (despite Rutorrent working perfectly fine it seems).


#12

Alright, looks like we’re getting there!

What is the output of ps aux|grep rtorrent


#13

Here we go:

P.S. The user interface is brilliant :slight_smile:

[[email protected]]:(924.3kb)~# ps aux|grep rtorrent
    kingblah  1692  0.0  0.0  29312  1276 ?        Ss   22:10   0:00 SCREEN -fa -dmS rtorrent rtorrent
    kingblah  1693  0.0  0.0 278940  8776 pts/1    Ssl+ 22:10   0:00 rtorrent
    root      9373  0.0  0.0  16356   988 pts/2    S+   22:18   0:00 grep --color=auto rtorrent
    [[email protected]]:(924.3kb)~#

#14

Why thank you! Putting my day job to good use other than making money :smile:

Ok… type pkill -f rtorrent, then wait about 45 seconds and refresh to see if the badges update as ‘enabled


#15

i will recommend changing it from raid 1 it will slow things down in long run for downloads mainly


#16

@kingblah
I’ve just done a new fresh install of Debian 8 by using the Custom Installation and ticked the box: “Use the distribution kernel”.

All that worked for me, and the Service Status is now showing the right information of rtorrent and iRSSi-Autodl :slight_smile:


#17

Still showing as “Disabled” which is really bizarre as the status on the disk tab reports:

Torrents in rtorrent
There are 1 torrents loaded

Titte95 - maybe I’ll give reinstalling and ticking that box a go. In practice, is there any difference between using Ubuntu (16) or Debian (8)?


#18

I am not sure. Both should resemble eachother. I’ve heard that Debian should be more stable? I am not 100% sure.


#19

It really is a matter of preference. In my opinion Ubuntu (especially coming into 16.04) is the better OS… only due to the vested interests that is being placed into maintaining and including packages and dependencies. Pretty much a bleeding edge Distro in terms of security updates and additional ppa’s.

Also, as @Titte95 said:

I should really make a note of this as we went round and round on this one until we noticed that their custom kernel is closer to trash than an actual kernel. Ticking that box is nearest thing to a unicorn for QuickBox.


#20

I was going to mention this, but it seems others have stumbled upon this too. grsec is built into OVH’s custom kernel and it absolutely wrecks havoc when using these panels where we depend on the ability for one user (www-data) to see the processes of another running user ($username). This can be seen clearly by using a task manager such as h/top. With grsec enabled you can only see the processes owned by your user unless you run htop as root. As such, I highly recommend the stock kernel for your distribution or at the very least installing an OVH kernel that is not compiled with grsec and we should probably make this a note in the readme