Fresh Install No rtorrent/rutorrent


#1

Hi I used to run QuickBox on Debian but you guys dont support it anymore so I installed Ubuntu 16.04 server 64 bit on my machine and have had tons of issues. i’ve tried formatting the OS 5+ times since each time something goes wrong with quickbox :frowning:

First of all rTorrent is always red even after fresh install

and its missing from the side bar

i always select 0.9.6

second of all, letsencrypt installer never works it always says vhost not found and then whenever I go to my ip address or domain it shows the default apache login page.

One time it did work but it still said insecure

Any suggestions?


Error 503 on everything
#2

this is a bug we are working on right now but to quick fix try
apt install -y rtorrent


#3

That fixed it, how do I get the black theme? Right now its white


#4

make sure that your hostname in the file /etc/hostname and /etc/hosts are the same. this could cause some problems also make sure the dns that you are using is able to see the server best way to do this is try to use it if takes you to server or not. also make sure the subdomain you are using is a valid one meaning no caps and no funky things just text.


#5

From your settings dropdown.


#7

Completely separate topic, but ok.

Did you do the final sed command?

sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

#8

When I do that I get this

sed: can’t read /etc/apache2/sites-enabled/000-default-le-ssl.conf: No such file or directory


#9

Ok, what does crontab -e show?


#10

everything is commented out
its just default text


#11

i just ran box install letsencrypt and ssl installed fine now.

Everythings looking good.

One small issue I have now is

[06.07.2017 17:06:33] screenshots: Plugin will not work. rTorrent user can’t access external program (ffmpeg).

anyone know how to fix that?


#12

Update: I did apt-get install ffmpeg and that resolved the issue. Everything is working fine now.

Thank you everyone!


#13

Just thought it would be worth mentioning that I had this exact problem and by following the steps on this forum, it’s been fixed! Cheers!


#14

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.