Dashboard on subdomain, how?!

dashboard

#1

Hello,

i have a question… how can i set all QuickBox stuff on a own subdomain? if i change something in

/etc/apache2/sites-enabled/default-ssl.conf

don´t work… and i need other websites on my server.

i want to set all on qb.domain.tld but try this for few hours :frowning:


#2

all you have to do is direct your dns to the server you should not have to change anything on the server. none of the apache files should be changed. you might set up let’s encrypt but make sure to follow our how to in our wiki.


#3

I dont think that will do it. The virtual host for QB is setup for listen for all incoming traffic. He needs to add a ServerName entry per https://httpd.apache.org/docs/2.4/vhosts/name-based.html and in any additional entries he creates for the new hostnames.

He’s asking to add additional virtual hosts to the apache server.

This missing optional entry is also the reason that Lets Encrypt will prompt for the config file to use.


#4

Okay works with Lets Encrypt, but how can i disable “Unauthorized” i need still the user:pass :confused:


#5

Removing auth to a service which controls your server is not recommended especially on a publicly accessible domain

That said, remove

AuthType
AuthName

From the configs you want to modify and alter

Require valid-user

to

Require all granted

#6

I need the login only on the qb.domain.tld but not on domain1.tld and domain2.tld. you understand!? :cold_sweat:


#7

Then you need to create separate vhosts for your other domains and define your server in default-ssl.conf

ServerName qb.domain.tld

In both port 80 and port 443


#8

well done, i only needed Require all granted in my new vHost.

Thank :kissing_heart:


#9

The little details can be a bitch sometimes can’t they? :wink:


#10

lel

but one question, this works only with https not http -.-

https://byte.wtf/m7wtyfd1.txt

if i add a domain.tld:80 this doesn’t work


Run php apps beside Quickbox
#11

You will need to create a vhost for the port 80 as well. ie;

<VirtualHost domain.tld:80>
ServerAdmin [email protected]
DocumentRoot /var/www/html/

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

ServerName domain.tld
<Directory />
    #Options FollowSymLinks
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order deny,allow
    Allow from all
    Require all granted
</Directory>
</VirtualHost>

<IfModule mod_ssl.c>
<VirtualHost domain.tld:443>
ServerAdmin [email protected]
DocumentRoot /var/www/html/

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLCertificateFile /etc/letsencrypt/live/domain.tld/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/domain.tld/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf

ServerName domain.tld
<Directory />
    #Options FollowSymLinks
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order deny,allow
    Allow from all
    Require all granted
</Directory>
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
</IfModule>

Want to be able to use a homepage
404 error index.html
#12

Thats what i needed, thanks :slight_smile: