Dashboard disk space missing, ruTorrent skin changed, and ruTorrent reporting no disk space available


#1

Okay so I am new to QuickBox, after I had issue with my previous reseller/hosing company I decided to go right to Kimsufi. I install Linux on it:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

I install QuickBox a few months ago 2.5.4 as a friend suggested it. I got everything up and running and everything seemed okay except I could not get the disk space on the dashboard to report anything other than 0. Since everything else was working I thought I would come back to it. Fast forward to this morning. I tried to figure it out and wamo I have really messed it up.
I followed a few post and thought maybe I could figure it out.



so now on to my issues:

  1. ruTorrent has changed the skin from black to white. I want the black one back.
  2. ruTorrent is now reporting it has no diskspace but before it said nothing.
  3. diskspace on the dashboard shows this now:
    Free:-0.00012207 GB
    Used:0.00012207 GB
    Size:0

show space command
299.8MB desktop/
744.9GB jameskirk

lsblk command
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 1.8T 0 disk
├─sda2 8:2 0 1.8T 0 part /home
├─sda3 8:3 0 511M 0 part [SWAP]
└─sda1 8:1 0 19.5G 0 part /

uname -a
Linux kronikseed 4.9.78-xxxx-std-ipv6-64 #2 SMP Wed Jan 24 10:27:15 CET 2018 x86_64 x86_64 x86_64 GNU/Linux

repquota -a command
*** Report for user quotas on device /dev/root
Block grace time: 7days; Inode grace time: 7days
Block limits File limits
User used soft hard grace used soft hard grace

root – 5088136 0 0 194144 0 0
man – 2808 0 0 93 0 0
lp – 308 0 0 1 0 0
www-data – 46696 0 0 4719 0 0
systemd-timesync – 0 0 0 1 0 0
syslog – 9616 0 0 19 0 0
_apt – 28 0 0 3 0 0
bind – 12 0 0 3 0 0
lightdm – 4 0 0 1 0 0
jameskirk – 128 0 0 28 0 0
vnstat – 84 0 0 21 0 0
debian-deluged – 12 0 0 3 0 0
debian-transmission – 28 0 0 7 0 0
shellinabox – 8 0 0 2 0 0

quota command for me
Disk quotas for user jameskirk (uid 1001): none

I have posted all what I think is the relevant information on this issue. I have also tried to reboot just in case someone thinks that will fix it, it didn’t. Thank you for the help a head of time.


#2

Can you try to uninstall the quotas?


#3

hello, thank you for your reply. yes I can remove the quota, I used the “sudo apt-get -- purge remove quota” command. This seems to fix the issue with ruTorrent freaking out. and on the dashboard I now have all 0 for the disk information. So 1 problem is fixed.

How can I get the disk information to read correctly?

how can I get the black skin back on ruTorrent?


#4

Hi,

You can switch themes from the rutorrent settings:
theme

For the disk space, try to play around with the diskspace and diskspaceh from your rutorrent plugins and check which one will work for you.
diskspace


#5

you can see here I have little to no experience with changing settings around. I did find the themes that you showed me. and that fixed it plus i see other themes in there too. cool beans.

initially the diskspace was installed, since that did not work, I uninstalled it. then I installed the diskspaceh, which changed nothing. i did also run the command “fix-disk_widget_home” while diskspaceh was installed nothing changed and it said command not found. so i uninstalled diskspaceh and installed diskspace, same results.

This is what I see on the widget:
image


#6

Are you logged in as root while doing the fix-disk_widget_home command?


#7

yes I am logged in as the root user and even do the sudo command.


#8

still doing the same thing still not working. anyone got anything?


#9

still looking for some help on this.


#10

have you tried the
setdisk command?
Type this command in ssh to allocate the amount of disk space you would like to give to a user.