CSF - Unable to load CSF control dashboard

needs-more-testing

#1

I installed the firewall and it seems to be working in the background as it keeps sending me e-mails
but I’m unable to go to the dashboard of the firewall at 3443

thanks for any help!


#2

I’ll check into this on an install here shortly.


#3

I have had same issue.


#4

@js8as & @lowfront

What linux distro are you guys using?


#5

Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-59-generic x86_64)


#6

Same issue here.

  • Installed as root using
  • installed in root folder
  • Using Let’s Encrypt with own domain
  • Ubuntu 16.04 LTS

#7

I reinstalled my box and now CSF works without issues. same OS.


#8

Whenever I reinstalled OS. CSF webUI would work only once. Then stop working again when I went to try again.


#9

I can confirm that at the moment there is something amiss with this. I will give this a closer review tomorrow.


#10

hey, same issue here, the webinterface is not loading for me, connection refused.
also running 16.04. lts, ubuntu
any news on this?


#11

Dont know why, but mine loads whenever I use server IP. With domain name it wont


#12

Checking on this now

I just ran updates on the development branch and CSF GUI is accessible after install.
I could access it via IP as well as https://domain.com:3443.

You want to jump on the dev branch and try it out @bate?

You should be able to run the following to hop on the development repos:

mkdir /install/ && touch /install/.developer.lock \
sudo box upgrade

#13

i also have this problem i have not been able to find a way into csf but it is sending me emails


#14

This is being tested later today as it’s a topic in our Development channel on chat at the moment.


#15

i am not super tech savvy but i can follow guides and copy and paste. if you need logs or something let me know how and i can send them assuming this is not happening for everyone


#16

any update on this? as it is still not working for me


#17

Nope. Making time for this today however.

###Update
Just ran the install with box install csf

[16101:16037 0:15] 03:31:07 Wed Apr 26 [[email protected]] ~
(1:15)# box install csf
Installing csf
Installing and Adjusting CSF (this may take bit) ...
Installing Sendmail (this may take bit) ...
Add an Administrator Email Below for Aliases Inclusion
Email: [email protected]

The email [email protected] is now the forwarding address for root mail
finalizing sendmail installation (please hold) ...


ConfigServer Firewall Installation Complete

You may now access the CSF UI on https://redacted:3443
Username: redacted
Password: redacted

Then was able to access via the dashboard created menu item

Then received the CSF login prompt

The CSF Dashboard was then available without error

Any chance @tv8tony you could inform me of which version of QuickBox are you on? I’m not receiving any errors on v2.5.1. If so, what is the status for CSF spitting out? Check it with systemctl status csf and let me know the output.


#18

at QuickBox v2.4.9
i updated to 2.5.1
BASH version is 4.3

i uninstalled csf
reinstalled csf
i am stuck at "access via the dashboard created menu item"
i get this page can not be displayed i have tried on ie and chrome i get emails but can not get into dash
the output to your command is is
You may now access the CSF UI on httpsxxxxxxxxxxxxxxx
Username: xxxxxxx
Password:

sd-100651:~# systemctl status csf
● csf.service - ConfigServer Firewall & Security - csf
Loaded: loaded (/etc/systemd/system/csf.service; enabled; vendor preset: enab
Active: active (exited) since Mon 2017-05-08 17:42:21 CEST; 39s ago
Main PID: 10407 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/csf.service

May 08 17:42:21 sd-100651 systemd[1]: Starting ConfigServer Firewall & Security
May 08 17:42:21 sd-100651 csf[10407]: csf and lfd have been disabled, use 'csf -
May 08 17:42:21 sd-100651 systemd[1]: Started ConfigServer Firewall & Security -
lines 1-9/9 (END)

i am sorry for the delay i somehow missed this


#19

update
i could not access Deluge web panel at myip:10986 it would just time out
the only thing i had changed was the above so i tryed to uninstall csf and Deluge now works
i am not a 100% they are related i only tried Deluge 5 times over like 10 mins befor uninstalled csf


#20

Here is the snippet in the CSF config template in regards to the ports that are allowed by default:

# Allow incoming TCP ports
TCP_IN = "22,25,53,80,110,143,443,465,587,993,995,3000,3443,4040,4242,4747,5757,5050,8000,8081,8181,8384,8888,8989,9117,20000:61000,65080"

# Allow outgoing TCP ports
TCP_OUT = "22,25,53,80,110,113,443,587,993,995,3000,3443,4040,4242,4747,5757,5050,8000,8081,8181,8384,8888,8989,9117,20000:61000,65080"

# Allow incoming UDP ports
UDP_IN = "22,53,3000,3443,4040,4242,4747,5757,5050,8000,8081,8181,8384,8888,8989,9117,20000:61000,65080"

# Allow outgoing UDP ports
# To allow outgoing traceroute add 33434:33523 to this list
UDP_OUT = "22,53,113,123,3000,3443,4040,4242,4747,5757,5050,8000,8081,8181,8384,8888,8989,9117,20000:61000,65080"

It looks like you would, in fact, have issues trying to access that port. You could add this to the list of allowed ports through the CSF GUI.