x2Go connection error


#1

Hi everyone,

I’m newbie on this site and my english is approximative so forgive me if i make some mistakes.

I discovered Quickbox a few years ago but don’t tried it until now. I want to make some tests to see if i like it. Seems to be really good as i can install x2go (need a graphical mode for an app).
So everything is ok after the installation of QuickBox on a Ubuntu 16.04 VPS.
Installation of x2go and xfce4 seems to be good too.

But once over, i tried to connect it with my x2go client (on Windows 10) and get this message :

kex error: no match for method server host key algo: server [ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nitsp256], client [ssh-ed25519]

If i undertsand, my Windows client don’t have enough level security ssh key to connect ? How can i fix it ?

Thanks a lot for your help :slight_smile:

Edit :
I tried something else tonight, i installed a Ubuntu 18.04 LTS on my VPS with xfce and x2go and have the same problem. So no link with QuickBox, seems to be a problem with my client but i don’t know why, test done with a debian server and it works.
x2go client downloaded this morning on the official website.

Do you have any idea ?