Widget Broken with last update


#1

Hey,

Since I cannot post in a similar thread as it’s closed, I got myself into trouble and it seems I cannot fix.
I’m on the dev branch for more than a month now, but with the latest “box upgrade” my widget is botched.

The dashboard lost Disk Status, Server Load, Ram Status, Recent Activity and Bandwidth Details.
I re-ran the updater, ran fix-disk_widget_root, rebooted, nothing works.

Can I get some help please?
Thank you.

PS: I’m an old QB supporter and user ever since it was in beta more than an year ago, somehow I am not able to post with my user, it requires activation even though it has been activated long ago.


#2

Hey, if the problem is on the dev branch, try to remove “.developer.lock” file in /install directory, remove the /etc/QuickBox directory and re-download the master branch only. It’s not the best solution but it worked for me…


#3

Hey @tomcdj71,
You mean delete .dev.lock and QB dir and re-run?

mkdir /install/ && touch /install/.developer.lock
apt-get -yqq update; apt-get -yqq upgrade
git clone --branch "development" https://github.com/QuickBox/QB /etc/QuickBox 

Thanks for clarification


#4

Yes, sorry,

try to do

rm -rf /install/.developer.lock && ~/QuickBox
apt-get -yqq update; apt-get -yqq upgrade
git clone https://github.com/QuickBox/QB /etc/QuickBox
box upgrade

It should work after. I think it’s a problem in the developer branch. The public branch works fine at the moment so be patient before returning to the dev branch


#5

Thanks, follow your advice and it solved my problem.
Cheers!


#6

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.