Why is "Your Disk Status" = zero


#1

I’ve just finished a clean install. Actually, twice. Latest build of Quickbox on Ubuntu 16.04 server. I installed on a 300GB drive, verified with a DF. When I view the console it shows zero disk space on the “Your Disk Status” panel. I’m assuming this has something to do with quotas. I basically took all of the defaults on installation and I noticed that quotas are on by default.

I see many posts that Disk Status isn’t working but it seems to be working fine, there is just no disk space available.

How do I configure Quickbox to show some disk space?

Thank you,


#2

Hi,

Can you login as root and launch fix-disk_widget_home ?

It happens if you had install QB on a home mount point :slight_smile:


#3

I ran that. It changed things, but didn’t fix them. Now the disk status shows blank. I can see Free:, Used:, Size: and the Disk Space bar but all have no entries.

I tried running “setdisk” both from SSH and from the Web Console but neither worked, showing “command not found”.

I’m happy to re-install. Are you suggesting I should first change directory to root “cd /”?

Thank you


#4

Are you running this command as root?

What are the results of the command lsblk?


#5

OK, now I’m a bit embarrassed. It worked as root but didn’t fix the problem. I rebooted afterwards but the disk information is still all blank. The following were run after first running sudo su. I’d previously (successfully) run the setdisk command.

Quickboxu1604:/home/name# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sr0 11:0 1 667M 0 rom
fd0 2:0 1 4K 0 disk
sda 8:0 0 300G 0 disk
ââsda2 8:2 0 1K 0 part
ââsda5 8:5 0 299.5G 0 part
â ââQuickbox–U16–vg-swap_1 253:1 0 4G 0 lvm [SWAP]
â ââQuickbox–U16–vg-root 253:0 0 295.5G 0 lvm /
ââsda1 8:1 0 487M 0 part /boot
Quickboxu1604:/home/name# setdisk

Disk Space MUST be in GB/TB - Do not attempt to add decimals in space settings,
Example - Good: 711GB OR 2TB, Example - Bad: 711.5GB OR 2.5TB

Username: name
Quota size for user: (EX: 500GB):
250GB
Quickboxu1604:/home/name#


#6

Will you run this command, as you may had ran the -home command above.

fix-disk_widget_root

See if that displays your data once more.


#7

Excellent. That did the trick.

Thank you very much.


#8

Oops sorry for the wrong command that i wrote.


#9

No worries. Thanks for your help.