Where can I find the file 'rpc.socket?'

rtorrent
ubuntu

#1

I’m having an issue establishing a connection with rutorrent, and I’ve read that deleting rpc.socket and restarting rtorrent will fix it. Normally the file can be found at:

/root/.rtorrent/rpc.socket

But this directory does not exist for me. Could it be possible the directory was made elsewhere? Where can I find this file?

Thanks


#2
/home/USERNAME/.config/rpc.socket

#3

Thank you. I opened .rtorrent.rc and found it also.

The problem is that the directory/file does not exist. Could that be what’s causing my connection issues?


#4

I a directory/file is specified in the .rc and its missing, I imagine it will cause some error, yes


#5

Would you by any chance know what should be in the file? Maybe I can create it manually (though I would’ve thought rtorrent would create it itself when starting up)


#6

I dont see it on my end either


#7

i can’t see it too… i have a error about Check $scgi_port… and i want to see if the port match in /home/USERNAME/.config/rpc.socket


#8

I don’t know what I did but I finally got my rutorrent to work again. Try force killing the rtorrent process and rebooting your server.

top

Find PID for rtorrent

kill -KILL <PID>


#9

Could it be the xmlrpc.php in /srv/rutorrent/php we are looking for?

i try sookie


#10

i still get this after try kill
No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.


#11

Did you reboot From27501?


#12

Yes i reboot


#13

in TOP can see rtorrent running


#14

Sorry, I’m new to rtorrent and linux so I’m not sure if I’ll be much help.
When you kill the rtorrent process, does it disappear from top?


#15

yes its disappear


#16

what happen if you run. rtorrent?
what do you get a output ?


#17

When I ran it as root it was fine, but as my other master account it said “could not prepare socket for listening address already in use”


#18

okay fine, you get the some output as me :slight_smile:

then i just have to google the problem som more :stuck_out_tongue:

i also have a problem with Dashboard

under Downloads - Deluge i get Error

The requested URL /from2750.deluge.downloads was not found on this server.

Apache/2.4.10 (Debian) Server at 23.2.23** Port 443


#19

After some research (and multiple run-ins with the same issue), it would seem that the problem lies with the rtorrent process crashing, which can be due to a number of reasons. The most common being: Removing large torrents, having a full disk, and a non-zero extreme swap (not sure what this means).

In my case, rtorrent crashes every time I remove a large torrent file, even if I’m not removing the data. This has happened at least 10 times now and my solution is to simply restart the service, or force kill it, or disable the service from quickbox dashboard, and then start it up again. If that fails I reboot the OS which seems to work.

I would like to know if there’s a way to remove large torrents safely, If they’re undergoing a hash check on slow servers it can take a long time to do (and it eats up system resources for other tasks).