Webmin + Quickbox


#1

I understand that Webmin may conflict with Quickbox but I was wondering if it would be ok to install as long as I do not enable or use any of the quota options? Will it still conflict with anything else?


#2

My experience in the past with webmin is that its of limited usefulness. It’s roasted more apache configs of mine than I care to think about. As a monitoring tool, I can see it. I would not use it to tweak anything on the system…ever.


#3

I’ve mostly used it for monitoring/information really but have used it for tweaking small things here and there in past via GUI rather then going into manual commands etc. Never really had an issue on previous setups.

Is there anything specific you know of that will conflict with Quickbox?


#4

I can’t think of anything off the top of my head that would directly be impacted from loading it. It’s mainly that it wants to do things its own way and if you’ve done them outside of it, then it will override your customized settings with its own and break things. Apache is where I’ve seen it do this the most…I have not tried to do it with quickbox. There are a million ways to do a specific thing in linux. QB goes about it one way and Webmin goes about it another…both will work but they might conflict if you’ve already done it another way and try to alter it in webmin.

I used to be a big webmin/virtualmin user back in the day but I found it just got in the way more than it helped. The one thing I do like about about it is the auto patching and email alerts on the patching. I still use that today on some of my non-production servers.

I think you’re fine to install and use it…just be aware that using it to edit things could cause conflicts and break things.


#5

Thanks. I may give it a go on a different test server see if it causes any issues.

To save on opening another thread, I was wondering if you knew what was issue I’m having with quota. I’ve installed fresh Debian 8 on a SYS server. I’ve been installing and deleting some test users with names as box1, box2 etc and deleting. However now when I create new users with those names the quota seems to screw up. It does not display in rutorrent and in dashboard it goes weird. I was setting quota as 500GB but getting the following in disk quota/usage even though the folder is empty. New users with different names don’t have any issue.


#6

On this subject, have you tried running a fix-disk_widget_home command?

Was it ever working and stopped… or has it always been off like this?


#7

I was unaware of this command. No it was not always like it. It only happened after a few creations/deletions of a specific username. Only seemed to be that specific name so must have been some leftover/problem files. I’ll check with this command later, thanks.

Do you know where the full command list is? Can’t seem to find one.


#8

@JMSolo or someone here might know? Shooting in the dark here myself. I haven’t seen an updated full length list of all the commands. I just happened to have seen Jason recommending that a lot to other users having similar user related issues.