Web Console - Listen Address? [Solved!]


#1

Edit: Never mind, turns out Safari just doesn’t like the web console - Chrome FTW!

Sorry to bother folks :slight_smile:

Hi Guys,

We’ve been testing some VMs with quick box before tonight’s roll out. I noticed that If I hit the server via the LAN IP (192.168.0.26) I can load the web console with no issues. If, however, I try to access via the openVPN IP (10.8.0.21) - I cannot load the webconsole.

The first thing I wanted to check is if there is a listen address specified somewhere that I need to configure? Failing that, anybody seen this before?

Valkyre14


#2

The IP is actually embedded in the proxy file for the webconsole. Not sure why that is vs ‘localhost’


#3

I’ve not encountered this particular issue.

Check out /etc/apache2/sites-enabled/USERNAME.console.conf the interior looks like this:
https://lab.quickbox.io/QuickBox/quickbox_setup/blob/master/templates/web-console.conf.template


#4

Is there a reason you use the IP in there?

The other example of reverse proxy for this used localhost.

ProxyRequests Off

<Proxy *>
AddDefaultCharset off
Order Allow,Deny
Allow from all

<Location /shell>
ProxyPass http://localhost:6125/
Order allow,deny
Allow from all

Redirect permanent /shell https://domain.com/shell

from here: http://www.htpcbeginner.com/increase-shellinabox-security/2/


#5

You can try it with localhost:PORT if you like. The ip of the install gets implemented in several configs, this is just one such location.


#6

Just came back to see all the replies, thanks folks

I appreciate you taking the time to reply, I just made a mistake (lack of sleep) apologies for wasting your time, it’s sorted now.


#7

No worries, glad you got this resolved… we really just look for an excuse to converse around here. Solved or not :smiley: