User Quota Error


#1

Hi,

Firstly, thank you so much for such an awesome script.

I have online.net server with me with mount as /home. I tried adding a new user today and I get the below error

setquota: Cannot open quotafile //aquota.user: No such file or directory

Screenshot:

http://imgur.com/vyGX04S

I am on Debian 8 and apart from the above error there is one error related to Plex which is not being shown in the dash board.


#2

Hi @atulsian, could you show me the contents of /etc/fstab?

As per the Plex, I just noticed I missed a small addition needed for the install script.

This can be fixed by doing the following:

mkdir /install
touch /install/.plex.lock

This will show Plex as installed as well as the menu item appearing as it should.

Thank you for bringing this to my attention!

Commit here:
https://github.com/QuickBox/quickbox_setup/commit/81d525ffe6df4b851067f1613a0ebec158759c40


#3

@JMSolo

Here is my /etc/fstab

http://pastebin.com/aNTkecQ3

Also, for the plex, I have already created a blank file in /install directory. The error still persists and I don’t see the Plex in my dashboard.


#4

Did you also do the following:

touch /install/.plex.lock

If the lock file doesn’t exist, it will not show the menu items.
As per the quota issue, it looks like you opted to install it on the root mount, rather than your /home mount.

Change this:

/ was on /dev/sda2 during installation
UUID=001a1c43-fcc5-4077-a603-acc9575b6ce4 / ext4 usrquota,error$

/boot was on /dev/sda1 during installation
UUID=216ffc85-83eb-457c-86e1-968e4c0972ea /boot ext4 defaults $

/home was on /dev/sda4 during installation
UUID=16d6c99f-996d-4eed-9a7f-bdbaf67ba99d /home ext4 defaults $

swap was on /dev/sda3 during installation
UUID=75daf973-d209-4fd1-b5ab-a789b54402f4 none swap sw $

To this:

/ was on /dev/sda2 during installation
UUID=001a1c43-fcc5-4077-a603-acc9575b6ce4 / ext4 defaults $

/boot was on /dev/sda1 during installation
UUID=216ffc85-83eb-457c-86e1-968e4c0972ea /boot ext4 defaults $

/home was on /dev/sda4 during installation
UUID=16d6c99f-996d-4eed-9a7f-bdbaf67ba99d /home ext4 usrquota,errors=remount-ro $

swap was on /dev/sda3 during installation
UUID=75daf973-d209-4fd1-b5ab-a789b54402f4 none swap sw $

#5

While installing I logged in as a root user and installed it. In the options it asked me if I want to use Home partition, I said yes and that’s it. How should I install it on my /home?

Sorry for bugging you.


#6

No, that is the right way to do it, however, I think their fstab had this errors=remount-ro listed on the root mount, thus it tried to modify that for quotas rather than /home, which they had set to defaults. I have never seen online.net do this with their fstab before… did you build these partitions yourself?

…and no worries, you are not bugging me. :slight_smile:


#7

Yes. On Online there was only option to add /home as a new partition and root, boot was selected by default.

I have changed the /fstab by replacing all the lines with the ones you pasted. Hopefully it is how I should have done it.

Edit: I tried changing /fstab it ain’t working. I’m doing a reinstall with the following partitions

http://imgur.com/A4roj9S

Please let me know if the above looks fine or should I leave all my HDD space on /root?

Thank you so much:-)


#8

You can remove that /home partition and just assign all space to /

####Edit: Reassigned this to the support category as this is not a bug.