User access to other folders


#1

Hi,

Just installed QuickBox and it seems to be 90% of what I need… Just have one little thing bugging me right now…

Opted for rtorrent and sickrage… I need my created user to have access to a special folder in those progs… Have seen topics like this on the Plaza, but pointing someone to fix a hosting detail on hdd is not what I am looking for…

My root user has connections to Amazon Cloud, from which I run encrypted mounts allowing me to have access to my entire cloud… I have create a username/cloud folder and mounted the unencrypted folder there, but sickrage/rtorrent is incapable of seeing that folder…

Can someone please give me the correct sintax to fix permissions ? This is a single user setup, all for me and no one else, so not to fazed about critical permissions…

Thank you in advance


Plex user rights to folders
#2

Is there a reason for the mounts being as root? My mounts are as my main user…most of the apps are tied around this main user.

I have my mounts mounted as my main user. The ‘apps’ are focused around that user so you’re best off mounting them as your main user. Plex does have it’s own account however.

In my opinion you’d be better off doing the mounts under the main user’s home directory, making them owned by your main user. That would take care of rtorrent and sickrage…for plex I use the ‘allow other’ fuse option to allow plex to see the data in the mount.

I assume by using 2 mounts that you’re using acd_cli+encfs? I use rclone.


#3

rclone is nowhere near stable enough for what I am doing…

And encfs can be decrypted to some degree by amazon as encfs doesn’t encrypt file names and sizes which means files can be tracked… (at least in last versions I checked)

I dont want my “media” user to have access to my amazon + encryption configs, thus the reason for the separation… And currently my mount total stands at 3, which might possibly go up to 4 based on future testing…

Care to share your “mount allow other” sintax? Also, would need Plex to be able to read that folder… any ideas?


#4

http://acd-cli.readthedocs.io/en/latest/FUSE.html

--allow-other, -ao
allow all users to access the mountpoint (may need extra configuration)

you’ll also need to edit /etc/fuse.conf and enable allow other in there too:
# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other


#5

–ao / --allow-other not working in my encryption mount…

doing this on a new vps as the media user… let’s see how it works out


#6

just an update, my mounts work within user space, thanks!