[Updated] Warning. Upgrading to Ubuntu 4.4.0-112-generic broke the server. (Kernel/Distro/boot full or all of the above as possible reasons for issues)


#1

UPDATE: After going into recovery and using KVM, I was able to pinpoint that the problem was regarding the update to 112 and the new Kernel it brought along. This all started because I usually update my server with the following command:

sudo apt-get update && time sudo apt-get dist-upgrade

I found the following resource that explains it can also be an issue with the /boot being at 100% capacity (which mine was at), and removing all old ubuntu versions as well as the new one.

https://ubuntuforums.org/showthread.php?t=1751574 (Last Post)

I was only able to boot back into ubuntu properly by using KVM, allowing it to get to the GBU GRUB ubuntu selection screen, selecting Advanced options for Ubuntu, and then selecting the previous distro I was one (109) (NON-Recvery Mode). Once in, I removed 112 and the previous Ubuntu distros leaving only 109 as the proper running one.

If anyone happens to know why this happened, or if it was just the /boot sector being full, let me know.

EDIT: Better question. Seems like the server isn’t turning back on correctly since I can’t ping it after waiting a while after a manual reboot (and many other remote reboots from the hetzner dash). If I use RESCUE, do I select Linux and can I do anything to recover access to the server and get it running properly as it was prior?

Can’t get into the server. This is after going to my server dashboard with Hetzner and trying all reboot options up to a manual one that was performed 30 minutes ago. Still nothing. Here’s the -vvv info that may help figure out what’s going on:

PS C:\WINDOWS\system32> ssh -vvv [email protected]_ADDRESS -p 4747
OpenSSH_7.5p1, without OpenSSL
debug3: Failed to open file:C:\Users\USERNAME/.ssh/config error:2
debug3: Failed to open file:./ssh_config error:2
debug2: resolving “IP_ADDRESS” port 4747
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to “IP_ADDRESS” [“IP_ADDRESS”] port 4747.
debug3: socket:488, socktype:1, io:00000200872E1670, fd:3
debug3: finish_connect - ERROR: async io completed with error: 10060, io:00000200872E1670
debug1: connect to address “IP_ADDRESS” port 4747: Connection timed out
debug3: close - io:00000200872E1670, type:1, fd:3, table_index:3
ssh: connect to host “IP_ADDRESS” port 4747: Connection timed out

Oh, and for some reason, It’s not pinging (but it’s been a while since the server was rebooted)

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for ip_address:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Hope this is enough, and I really appreciate the help. Kinda spooked since I’d probably cry a little if I have to do a full reformat.


#2

Get server online before trying to ssh into it… jk :wink:

Try to do a reboot in heztner control panel and then ping/ssh it again


#3

Hey, thanks for the reply. Yeah, I’m a dummy since clearly I can’t get anywhere unless the server pings. I just don’t understand why after all these reboots even with a manual one, the server still isn’t up after 45min. I guess I’ll wait a bit longer. Do you know how long it takes for the server to come back online after a manual reboot once they do it?


#4

It definitely don’t take 45 min for the server to get online.
You might just be better of doing a OS reinstall and start all over


#5

Refer to first post.