Update breaks Quickbox web and Deluge web


#1

Just updated from I think 2.4.2 to 2.4.4 and it seemed to go fine. Got the slightly rearranged QuickBox interface.

A few minutes later I tried to look at it again and I am getting 500 errors. Same with deluge. But strangely enough the rutorrent page still works.

Thought it must need a reboot after updating, but its still the same afterwards. Tried connecting from another server I have just to rule out something wrong with my local connection and still doesnt work.


#2

Could you PM me with your server details and I will take a look. We’ve not had anyone encounter this, but it may help me find anything unusual to avoid in updates.


#3

That idea doesnt really appeal to me tbh, giving my details to a complete stranger.

Its only a bog standard OpenVZ VPS Debian 8.


#4

Ok, it’s your call.

Your issue however is going to be with OpenVZ

:loudspeaker: Heads up!

Though this script is valid for both VPS & Dedicated Environments, please be advised the it’s support is limited on OpenVZ environments due to lack of kernel control. If you are installing on OpenVZ quotas and additional hooks may not work.


#5

Yeah, but it worked fine on 2.4.2 and it worked fine on 2.4.4 for 5 mins. I dont use quotas.

And obviously the fact that its stopped deluge web working is a strange one.

Having trouble finding the change log between the 2.


#6

Again, OpenVZ has no kernel control and is handled at the host machine level. Therefore, any issue may occur that is the fault of the hosting source. If you have issues upstream it will make troubleshooting incredibly difficult. By DelugeD going offline, this only drives that point to home. It’s not just quotas, it’s additional hooks. This rolls over to services/processes as well.


#7

@JMSolo is not a stranger he is the creator of this project. he is the only one who could just look and see whats wrong with your server.

That being said you installed our script. if we were out to hurt you don’t you think that would be part of the script?

We are working on writing up change logs. takes time to do. and as this is open source you could just look at the script itself.


#8

From 2.4.2 to 2.4.4 the only additions/changes made were:

###Applications added - version bump 2.4.2 - 2.4.3
Syncthing added
CSF (firewall) added

###Security - version bump 2.4.3 - 2.4.4
Require specific user to access https downloads directory

###Aesthetics - version bump 2.4.3 - 2.4.4
Sortable widgets
Bandwidth chart aesthetics


#9

I’m looking through the code, but I’m a windows programmer.

Just occurred to me, just before it stopped working I hit the disable web console button as I have no use for that feature.

Is there a command to restart that service, or will it have restarted as part of the reboot? It might just be a coincidence but that was the last thing I did.

I wasnt trying to be disrespectful with the “stranger” comment, sorry if you were offended.


#10

No worries, I am not offended. It’s a matter of choice and I like to figure these issues out hands on in order to prevent potential pitfalls for future users… without access to such environments it makes the troubleshooting incredibly difficult as I can’t possibly give a definitive answer to the 100 potential variables.

You could restart the web console by typing in systemctl restart shellinabox

PS: good call on the changelog… I am taking time now to publish all the commits that have been made. To that I do apologize. :blush:


#11

That did restart the Shellinabox, but no effect on loading the quickbox webpage.

You know when you click on button that enables and disables the shellinabox has that been changed to do anything new, or that might conflict with something?

Deluge web interface is working. I dont know if that restarted when I rebooted, and I just assumed it wasnt because the Quickbox page wasnt loading. Its late here. Time for bed.


#12

Anything in the apache error log? /var/log/apache2/error.log

500 server error is probably something that we should see a trace for somewhere.


#13

Yes! I saw this last night, but didnt thing too much about it with it mentioning utorrent and that being the only thing that was still working.

This is the error:-

PHP Parse error: syntax error, unexpected ‘;’ in /srv/rutorrent/home/inc/config.php on line 14

When I have looked at this file, its actually not just for rutorrent as I can see lots of Quickbox references in it.

Line 14 was

$interface = ;

So I changed that to

$interface = venet0;

restarted Apache

And we now have a Quickbox web interface coming up!! And back to normal!


#14

Thanks for the reply @Jason and the solution.

That looks like the script didn’t write the adapter over the INETFACE text.

Just to confirm, are the other settings filled in with your proper network adapter?

// Network Interface
$interface = INETFACE;
$iface_list = array('INETFACE');
$iface_title['INETFACE'] = 'External';
$vnstat_bin = '/usr/bin/vnstat';
$data_dir = './dumps';
$byte_notation = null;

####Post Script:
A lot of those errors can safely be ignored in the error log. A lot of them are coming from hard-coded values that cannot be read dynamically by php, i.e; Network Adapters and CPU threads, etc etc.


#15

Its not quite that, this is what I have:-

// Network Interface
$interface = venet0;
$iface_list = array(’’);
$iface_title[’’] = ‘External’;
$vnstat_bin = ‘/usr/bin/vnstat’;
$data_dir = ‘./dumps’;
$byte_notation = null;


#16

Yeah, then you’ll need to place venet0 in each of those slots I have above. Anywhere it says INETFACE. I’ll look at this tomorrow closer and see what could potentially be making these values blank.


#17

Great, thanks for your help.

Just looking through your code, the same problem was in

/widgets/bw_tables.php

The “view additional bandwidth” box never worked. But I didnt really care as it wasnt core functionality for me. Pasting the interfaces in, now means that works too.

I wonder if this is why the bandwidth graph / chart never worked also? Checking data.php the first line was interface =; But setting it to venet0 does not give me a graph. I’ll let you know if I get it working.

Ok the graph now works too. In data.php there was another line with no value namely

$data[‘label’] = ;

Which I just set to any value, and we now have a blue line in the middle of the graph - never had that before. Sadly it isnt showing bandwidth usage, yet.


#18

These are the files it reads from:

/srv/rutorrent/home/widgets/stat.php
/srv/rutorrent/home/widgets/data.php
/srv/rutorrent/home/widgets/bw_tables.php
/srv/rutorrent/home/inc/config.php

Looks like you found them all, just missing stat.php


#19

in data.php I have the following:-

$rx[] = @file_get_contents("/sys/class/net//statistics/rx_bytes");
$tx[] = @file_get_contents("/sys/class/net//statistics/tx_bytes");
sleep(1);
$rx[] = @file_get_contents("/sys/class/net//statistics/rx_bytes");
$tx[] = @file_get_contents("/sys/class/net//statistics/tx_bytes");

changed to

$rx[] = @file_get_contents("/sys/class/net/venet0/statistics/rx_bytes");
$tx[] = @file_get_contents("/sys/class/net/venet0/statistics/tx_bytes");
sleep(1);
$rx[] = @file_get_contents("/sys/class/net/venet0/statistics/rx_bytes");
$tx[] = @file_get_contents("/sys/class/net/venet0/statistics/tx_bytes");

But still no graph. Hope what I am doing is helpful :slight_smile:

stat.php has the same problem

$interface = ;
$data[‘rec’] = exec(“cat /sys/class/net//statistics/rx_bytes”);
$data[‘snd’] = exec(“cat /sys/class/net//statistics/tx_bytes”);

Ohhhh with that fixed we now have a very pretty blue graph!


#20

you can trust JMSolo, he helps so many ppl and nobody complains.