Unable to update

Hi, I’m trying to update but it’s not responding. In the dashboard it just says ‘qb autocomplete enabled’, and when I try in the CLI I get ‘command not found’ using ‘qb update’, after running ‘sudo su -’.

I have tried rebooting the machine once already, am I missing something obvious here?

Currently using v2.0.8


Hey there @blackice85,

Can you show me the output of la -l /etc/QuickBox

ls: cannot access ‘/etc/QuickBox’: No such file or directory

I guess I’m missing something then.

Yup, looks like you’re missing a whole lot. Will you run the following in ssh as root:

apt -y update && apt -y upgrade
apt -y autoremove && apt -y autoclean

Then run (it’s states 164 as it resets to that version number - useful for getting your sources back):

wget -q https://lab.quickbox.io/QuickBox/Pro/raw/master/qb164Update && chmod +x qb164Update && ./qb164Update && rm -f qb164Update

After you run that, do:

qb fix dpkg

And finally to get you up to v2.1.0:

qb fix version

Looks like that solved it, thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.