Unable to connect users via ssh

lshell

#1

Hello,

Since I’ve changed the /etc/lshell.conf, my users can’t connect via ssh, when I try :

su test
Traceback (most recent call last):
File “/usr/bin/lshell”, line 52, in
main()
File “/usr/bin/lshell”, line 38, in main
userconf = CheckConfig(args).returnconf()
File “/usr/lib/python3/dist-packages/lshell/checkconfig.py”, line 71, in init
self.get_config()
File “/usr/lib/python3/dist-packages/lshell/checkconfig.py”, line 286, in get_config
self.get_config_sub(‘default’)
File “/usr/lib/python3/dist-packages/lshell/checkconfig.py”, line 316, in get_config_sub
conf = self.config.items(section) + conf
File “/usr/lib/python3.5/configparser.py”, line 855, in items
return [(option, value_getter(option)) for option in d.keys()]
File “/usr/lib/python3.5/configparser.py”, line 855, in
return [(option, value_getter(option)) for option in d.keys()]
File “/usr/lib/python3.5/configparser.py”, line 852, in
section, option, d[option], d)
File “/usr/lib/python3.5/configparser.py”, line 393, in before_get
self._interpolate_some(parser, option, L, value, section, defaults, 1)
File “/usr/lib/python3.5/configparser.py”, line 443, in _interpolate_some
"found: %r" % (rest,))
configparser.InterpolationSyntaxError: ‘%’ must be followed by ‘%’ or ‘(’, found: “%u’”

What I’ve changed in the lshell.conf are just allowed and forbidden lign (adding rclone and delete ‘&’), here’s my lshell.conf :

[global]
logpath : /var/log/lshell/
loglevel : 2

[default]
allowed : [‘cd’,‘cp’,’-d’,’-dmS’,‘git’,‘irssi’,‘ll’,‘ls’,’-m’,‘mkdir’,‘mv’,‘nano’,‘pwd’,’-R’,‘rm’,‘rtorrent’,‘rsync’,’-S’,‘scp’,‘screen’,‘tar’,‘unrar’,‘unzip’,‘nano’,‘wget’,‘rclone’]
forbidden : [’;’, ‘|’,’`’,’>’,’<’, ‘$(’, ‘${’,‘sudo’,‘vi’,‘vim’,’./’]
warning_counter : 2
aliases : {‘ls’:‘ls --color=auto’,‘ll’:‘ls -l’}
intro : "== Seedbox Shell ==\nWelcome To Your QuickBox Seedbox Shell\nType ‘?’ to get the list of allowed commands"
home_path : ‘/home/%u’
env_path : ‘:/usr/local/bin:/usr/sbin’
allowed_cmd_path: [’/home/’]
scp : 1
sftp : 0
overssh : [‘ls’,‘rsync’,‘scp’]

Thanks per advance for your help !


#2

Ok … I just reinstalled the machine and in fact I have this error immediatly ! Is it an incompatibility with Unbuntu 16.10 ? I’ll try with 16.04


#3

Ok with 16.04, sorry !


#4