Unable to connect to webUI

letsencrypt
16.04
install

#1

I’m pretty sure I screwed up installing Let’s Encrypt on top of my Quickbox installation
I was not sure if it was installed when I updated my installation yesterday from 2.4.x to now 2.5.1.
I can connect via SSH or FTP, just cannot connect via the webUI, I’m sure my apache settings are messed up.
And I am unsure of how to solve the issue. Any assistance or guidance would be appreciated

Thanks


#2

The easiest way to do this is the following:

  1. Remove any certs generated at /root/.acme.sh
  2. Restore the default apache config for default-ssl.conf located at /etc/apache2/sites-enabled/default-ssl.conf
    at line 40-41 you will see where the “supposed” generated cert has been installed. Remove those lines and replace them with the following default:
        SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
  1. Now signal a restart to apache with service apache2 restart

With that done, you should now be able to access your dashboard, as well as work on generating a new certificate for your domain with box install letsencrypt


#3

Thank you very much, that work beautifully.
Now to try again


#4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.