Unable to access deluge

deluge

#1

I am having some issues with deluge that hopefully I can get assistance with. I am unable to access deluge I get a connection refused message.

Starting yesterday I had an issue where deluge was not downloading anything, so I uninstalled deluge via the dashboard. I went in an reinstalled deluge via the dashboard.

Clicking on the deluge link it brings me to localhost:10388 which I am unable to access.

I have upgraded Quickbox, reinstalled deluge several times and each new link does not work

However, I am able to access deluge on the first port which was 10725.

Now the issue is in the Deluge connection manager the status is offline, click on Start Daemon does not work.

Does anybody have any suggestions?


#2

What does systemctl status [email protected] show?

Also, make sure the link is not redirecting to https:// and for added measure, flush your browser cache or attempt to access the link via a new browser.

If the status is down then you can issue a restart with systemctl restart [email protected] and to restart the web daemon do systemctl restart [email protected]

I highly doubt it would simply stop working, this would more than likely result in some tweaking gone wrong or permissions adjusted. You can also use box (the CLI version of the Package Management Center) to do the install/removal of Deluge, see if that yields better results, however, the two are one in the same.


#3

systemctl status [email protected]

I have restarted deluge just for good measure which is still not working.

I should explain no tweaking was done, I use deluge for downloading files to my NAS. Rtorrent is my main client.

This is what I get when trying to uninstall and reinstall deluge via the box command

Also tried from another computer same result and no https in the address bar.


#4

Deluge-Web is accessed directly via the port. You cannot access it via https://

Also, there should be USERNAME.info file located at /root/, have you possibly removed this file?


#5

I have not removed any files
In the root directory I have a USERNAME.info.db file but not just .info
Am I able to recreate this?


#6

Create the file and it’s contents should have the following:

#   https://USERNAME:[email protected] (Also works for FTP:5757/SSH:4747)

Not entirely sure why that file would be missing, it’s created on install. What version of QuickBox are you running by the way?


#7

Still did not work, still unable to load the page. Do I need to restart the entire box?

Looking at the Dashboard I have v2.5.1


#8

You need to reinstall Deluge after you have created that file as it reads the username and password within that file to build it. Remove/Reinstall and try to access via the dashboard link it creates, no https:


#9

Super embarrasing
So when you said the root folder I thought you meant the root user
In my root home folder I do have that username.info

I go in and reinstall deluge, which changes the “port” the Dashboard tries to open, however I still get a connection refused message.


#10

Could you PM me with details to your server and I can take a look?


#11

Wont let me PM you, says I am not authorized to do so.


#12

Solved via PM