Trouble upgrading?


#1

So twice now I have installed Quickbox onto my VPS because the first time I thought there might be a problem. Immediately after reboot I the VPS informs me that 3 packages can be upgraded. So I run apt-get update and apt-get upgrade as root. The apt-get upgrade seems to work fine but I’m getting the following message when running apt-get upgrade:

~# apt-get update
Hit:1 http://archive.canonical.com/ubuntu xenial InRelease
Hit:2 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:3 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease
Get:4 http://archive.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:5 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Get:6 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Fetched 323 kB in 0s (361 kB/s)
Reading package lists... Done
diehardbattery:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  amd64-microcode intel-microcode iucode-tool thermald
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up linux-image-4.12.14-041214-generic (4.12.14-041214.201709200843) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.4.0-128-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.12.14-041214-generic /boot/vmlinuz-4.12.14-041214-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.12.14-041214-generic /boot/vmlinuz-4.12.14-041214-generic
update-initramfs: Generating /boot/initrd.img-4.12.14-041214-generic
E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.12.14-041214-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.12.14-041214-generic.postinst line 1052.
dpkg: error processing package linux-image-4.12.14-041214-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up linux-image-4.4.0-128-generic (4.4.0-128.154) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.12.14-041214-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-128-generic /boot/vmlinuz-4.4.0-128-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-128-generic /boot/vmlinuz-4.4.0-128-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-128-generic
E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.4.0-128-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.4.0-128-generic.postinst line 1052.
dpkg: error processing package linux-image-4.4.0-128-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-extra-4.4.0-128-generic:
 linux-image-extra-4.4.0-128-generic depends on linux-image-4.4.0-128-generic; however:
  Package linux-image-4.4.0-128-generic is not configured yet.

dpkg: error processing package linux-image-extra-4.4.0-128-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-4.12.14-041214-generic
 linux-image-4.4.0-128-generic
 linux-image-extra-4.4.0-128-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

On a possibly related note, I’ve seen that there is a version 2.5.5 of Quickbox, but every time I’ve installed it says version 2.5.4?