Transdroid configuration


#1

Hi

I tried quickbox and it’s great !

I don’t like the mobile view so I want to try transdroid.

Do you know the informations to give to transdroid ?

I set port to 443 and just enter the IP / credentials but it’s not working.

Thank


#2

It works for me…you need to specify the settings under the advanced menu

Advanced Settings:


#3

I try like you but it doesn’t work.

Do I need to do something on quickbox side ?


#4

Try the last checkbox about accepting all certs. I have a legit cert on mine so I don’t need that one checked.


#5

It doesn’t work :neutral_face:

Maybe a problem with HTTPS, do you know, if we can disable HTTPS in quickbox ?

Or maybe a problem with mount point ?


Transdrone Configuration - Need help
#6

Are you trying this as your master user or a different user? Are you sure your password is correct?

Do you have any errors?

Mine works but I only have my master user.

The mount of /rutorrent/plugins/httprpc/action.php should be correct if the httprpc plugin is loaded.
I have had this setup on multiple quickbox systems and its always been this way.


#7

I try with my quickbox master account.

I don’t have error, just no connection or tansdroid sudendly close.


#8

@Hydro8, please double check your settings to verify that everything is in place. As @RXWatcher has stated:

The mount of /rutorrent/plugins/httprpc/action.php should be correct if the httprpc plugin is loaded.

Please ensure that this plugin is enabled via your dashboard on the plugins tab. I can confirm that these settings are in working order if followed properly.


#9

This plugin is enable in the dashboard, I only desactivate “ipad” plugin.

I’ve got an online.net server without ssl certificate. Every time I open transdroid, it says “no connection”.


#10

What happens when you go to the address using a browser?

https://IP address/rutorrent/plugins/httprpc/action.php
And login?

You should get a ‘false’ response from the server


#11

Yes I’ve got false. HTTPS is strikethrough, I don’t know if it’s normal.


#12

it just means you arent using a legitimate cert. It’s a self-signed cert.

I would delete this server in the transdroid client and start again. Something is amiss in the client setup as that url worked for you. You will need to check that last check box to accept all certificates because you are using a self signed cert.


#13

Additional to this, since I am such a nice guy. Feel free to PM me here on the plaza or shoot me a DM via the QuickBox Live Chat and I will install Let’s Encrypt on your server for you and add you to the QuickBox DNS.


#14

I try with the certificate of JMsolo but it doesn’t work, transdroid automatically close when I choose ssl.

I try to reinstall but it doesn’t change a thing.


#15

Just wanted to confirm these steps work perfectly with a let’s encrypt setup
no need to accept all SSL certs - first time round I did miss the “port number” setting :slight_smile:


#16

Did someone use transdroid with online.net server ?


#17

I have in the past. I used to have nothing but online.net boxes…probably 5 in the last year or two. QB and Transdroid worked fine.

Why dont you paste your screenshots like I pasted mine?


#18

I’m using it right now bud with the screenshots above (Ubuntu 16.04 if that’s relevant)

edit: changed ubuntu version to correct one, not that I think it matters for a second :slight_smile:


#19

I’m using debian, I don’t know if it’s change a thing.

Did you change something on quickbox plugin ?


#20

Sorry I don’t see your post before, here my screen :